Module 17: Linking Models, Parameters, Library Package and Updates
Module 17: Linking Models, Parameters, Library Package and Updates

17.1 Adding Model and Parameter Detail to a Component .......... 17-1
   17.1.1 Adding a model ........................................................................................................... 17-1
   17.1.2 Exercise – Adding a footprint using the Model Manager ..........................17-2
   17.1.3 Component Parameters .................................................................................. 17-4
   17.1.4 Exercise – adding a component parameter .................................................17-5
   17.1.5 Adding and Modifying Component Parameters ...........................................17-6
   17.1.6 Exercise – Editing Parameters in the Parameter Manager ........................17-7

17.2 Component Auditing ............................................................... 17-8
   17.2.1 Schematic Updating .......................................................................................... 17-8
   17.2.2 Updating PCB Footprints .............................................................................. 17-10
   17.2.3 Other Audit techniques .................................................................................. 17-11
   17.2.4 Exercise – Using the new component in schematic ................................ 17-12

17.3 3D PCB Components .............................................................. 17-14
   17.3.1 Using Altium Designer’s 3D Body Objects ................................................ 17-14
   17.3.2 Importing a 3D STEP Model ........................................................................... 17-15
   17.3.3 Rotating and Positioning the STEP model .................................................17-16
   17.3.4 Exercise – importing a STEP model ..........................................................17-16

17.4 Library Package types ............................................................ 17-18
   17.4.1 Integrated Libraries ....................................................................................... 17-18

17.5 Library Reports ........................................................................ 17-20
   17.5.1 Library Editor Reports .................................................................................. 17-20
17.1 Adding Model and Parameter Detail to a Component

The final stage of preparing the new component is to add model and parameter information.

17.1.1 Adding a model

There are a number of ways of adding a models to a component, these include:

- Via the Library Component Properties dialog
- Via the models region at the bottom of the main workspace – click the small down arrow at the bottom right of the workspace if it is not visible.
- Via the Model Manager. The Model Manager allows you to add models to multiple components at the same time, and is ideal for reviewing model assignments across a library.

Figure 1. Add and manage component models at the bottom of the editing window, or in the Model Manager
17.1.2 Exercise – Adding a footprint using the Model Manager

To add a footprint using the Model Manager:

1. If it is not already open, re-open the Temperature Sensor project (`Program Files\Altium Designer Summer 09\Examples\Training\PCB Training\Temperature Sensor\Temperature Sensor.PrjPcb`).

2. In the Projects panel, browse to and open the schematic library, Temperature Sensor.SchLib.

3. Select Tools » Model Manager in the Schematic Library Editor to open the Model Manager. It will show a list of all components in the current library and any models, including Footprint, Simulation, Signal Integrity, and PCB 3D models.

4. In the Model Manager dialog click on the TCN75 component that you created, making it the active part.

5. Click Add Footprint to launch the PCB Model dialog, as shown in Figure 2.

![PCB Model dialog](image)

*Figure 2. Adding the footprint model to the component.*
6. If you know the footprint name, and you are confident that it is in a currently available footprint library, you can type the name directly into the Name field, an image of it will appear if it is located. Otherwise, you can click Browse to open the Browse Libraries dialog, as shown in Figure 3.

**Note:** There are different ways you can reference a footprint from the symbol, this is determined in the PCB Library region of the PCB Model dialog:
- **Any** means find the footprint in Any currently available library,
- **Library Name** means it must come from the specified library,
- **Library Path** means it must come from the specified library in the specified location, and
- **Use from integrated** is set automatically if you have compiled the library into an integrated library.

![Browse Libraries dialog](image)

**Figure 3.** Use the Browse Libraries dialog to visually select the correct footprint.

**Note:** The Libraries dropdown at the top of the dialog allows you to choose which library you are currently browsing, from the available footprint libraries. The Find button is used to search, this will be demonstrated in the Schematic Capture training module.

7. Once you have located your new SOIC8 footprint select it, and it will appear in the PCB Model dialog. Click OK to close the dialog.

**Note:** If your footprint was using a different numbering scheme from the pin numbering on the symbol you would need to define the pin-to-pad mapping, click the Pin Map button in the PCB Models dialog to do this.

8. Click Close to close the Model Manager, you have now assigned the SOIC8 footprint to your TCN75 component.

9. Save the library.
17.1.3 Component Parameters

Each component that you create can have any number of component parameters, which can be added/edited in the library or on the schematic. Parameters can be used for any purpose you require, including:

- component detail information, such as a voltage rating, component revision, and so on
- company component information, such as stock number or price,
- design reference information, such as special pick and place requirements,
- links to reference information, such as websites and PDFs.

<table>
<thead>
<tr>
<th>Visible</th>
<th>Name</th>
<th>Value</th>
<th>Type</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Code_JEDEC</td>
<td>TO-52A</td>
<td>STRING</td>
</tr>
<tr>
<td></td>
<td>ComponentLink10_exception</td>
<td>Manufacturer Link</td>
<td>STRING</td>
</tr>
<tr>
<td></td>
<td>ComponentLink1URL</td>
<td><a href="http://www.fairchipsemi.com/">http://www.fairchipsemi.com/</a></td>
<td>STRING</td>
</tr>
<tr>
<td></td>
<td>ComponentLink20_exception</td>
<td>Datasheet</td>
<td>STRING</td>
</tr>
<tr>
<td></td>
<td>ComponentLink30Rl</td>
<td><a href="http://www.fairchipsemi.com/ds/2N3905/">http://www.fairchipsemi.com/ds/2N3905/</a></td>
<td>STRING</td>
</tr>
<tr>
<td></td>
<td>DatasheetDocument</td>
<td>1997</td>
<td>STRING</td>
</tr>
<tr>
<td></td>
<td>LatestRevisionDate</td>
<td>15Jan2003</td>
<td>STRING</td>
</tr>
<tr>
<td></td>
<td>LatestRevisionNote</td>
<td>PCB Footprint 'BCY W3/3/04.' replaced</td>
<td>STRING</td>
</tr>
<tr>
<td></td>
<td>PackageDocument</td>
<td>Sep-1998</td>
<td>STRING</td>
</tr>
<tr>
<td></td>
<td>PackageReference</td>
<td>TO-52A</td>
<td>STRING</td>
</tr>
<tr>
<td></td>
<td>Published</td>
<td>$Jun-2000</td>
<td>STRING</td>
</tr>
<tr>
<td></td>
<td>Publisher</td>
<td>Albaum Limited</td>
<td>STRING</td>
</tr>
</tbody>
</table>

Figure 4. Add parameters to fully describe your components.

Any component parameters can be included in the Bill of Materials, or any custom report you generate via the Report generation dialog.

Figure 5. Generate reports that include any component data you require.
17.1.4 Exercise – adding a component parameter

A useful component parameter is to add is a link from the schematic component to a datasheet. A PDF datasheet for the serial temperature sensor component has been included, we will now add a parameter that allows us to open the datasheet for it directly from the schematic.

1. In your Windows File Explorer, confirm that the PDF datasheet is available. Browse to the location:
   
   C:\Program Files\Altium Designer Summer 09\Examples\Training\PCB Training\Temperature Sensor

2. In the Windows File Explorer, copy this address location (you might need to enable the Address Bar via the View » Toolbars menu first).

3. Return to Altium Designer, then with your TCN75 component symbol open in the library editor, double click on its name in the SCH Library panel to open the Library Component Properties dialog.

4. In the Parameters region of the dialog, click the Add button to add a new parameter, this will open the Parameter Properties dialog.

5. In the Name field, type HelpURL.

6. Click to position the cursor in the Value field of the dialog, then Paste in the contents of the Windows clipboard, this should be what you copied from the Address Bar of the Windows File Explorer, namely:

   C:\Program Files\Altium Designer Summer 09\Examples\Training\PCB Training\Temperature Sensor

7. Type a backslash (\) character at the end of the string, then type in the name of the PDF, namely: TCN75 - 21490b.pdf, as shown in Figure 6.

8. Clear the Visible checkbox in the Parameter Properties dialog since there is no need to show this string on the schematic.

9. Click OK to close the dialog, then click OK to close the Library Component Properties dialog.

10. Save the library.

   **Note:** We'll use this link we have created shortly in 17.2.4 Exercise – Using the new component in schematic.
17.1.5 Adding and Modifying Component Parameters

Parameters can be added to an individual component, either in the schematic library editor, or the schematic editor. Adding parameters at the library level ensures consistency in component information and speeds the process of component placement as parameters do not need to be added individually.

Altium Designer also provides a powerful Parameter Manager that supports adding parameters globally to a library, schematic, or series of schematics.

To open the Parameter Manager:

- In either the Schematic or Schematic Library editors, select Tools » Parameter Manager from the menus to launch the Parameter Editor Options dialog.
- Enable the Include Parameters Owned By check boxes you require, if you are editing components this would typically only be the Parts option, then click OK.
- The Parameter Table Editor will open. Column headings correspond to the parameter names, with the contents of each column corresponds to that parameter's value. Figure 7 shows the Parameter Table Editor.
- Right-clicking in the Parameter Table Editor will display options, such as Add Columns, Add Parameter Values, Copy, Paste, and so on. Data can also be pasted from standard text and from most spreadsheet applications, such as Microsoft Excel.
- All parameter changes are controlled by an Engineering Change Order (ECO) process that supports the controlled execution of ECO's, including the ability to selectively include and exclude operations as well as generate reports of all changes prior to their being executed.

**Note:** once you have selected an item (or items) in the Parameter Manager, press F2 to edit the value(s).

---

**Figure 7. Parameter Table Editor**
17.1.6 Exercise – Editing Parameters in the Parameter Manager

We’ll add a new parameter, called Lead Time, to all the components in the Temperature Sensor schematic library.

1. From the Temperature Sensor.schlib schematic Library, select Tools » Parameter Manager and in the initial dialog, be sure only Parts is checked in the Include Parameters Matched By section at the top, leaving the other options set to their defaults, the click OK.

2. In the Parameter Table Editor, right-click and choose Add Column.

3. In the Name field, enter Lead Time, checking the Add to all objects option. Leave the Value field blank, and click OK. A new column will be created with the heading Lead Time, at the right hand edge of the dialog (scroll across if necessary).

4. Right click the contents of the column Lead Time for the component DMC-50448N and select Edit. The field will change to a drop-down with a cursor. Type 14 days in the field, and press Enter to commit the value.

5. Right click on this value of 14 days, and select Copy.

6. Right-click the field Lead Time for the component TCN75, and select Paste.

7. Select all the cells of the column Lead Time (not including the column heading) using either Ctrl+Click, Shift+Click, or dragging to select the contents fields.

8. Right-click on any of the 3 selected cells and select Edit. One of the 3 cells will become editable. Type the text 3-5 Days and press Enter on the keyboard. All selected cells will have the edit applied. Using these standard spreadsheet-type editing actions, multiple cells (including columns and rows) can be edited.

9. Click Accept Changes (Create ECO) to open the Engineering Change Order dialog. This is list of changes that are about to be applied to the library, note that individual changes can be disabled.

10. Click the Execute Changes button in the ECO dialog to propagate those changes through to the design. The Report Changes button will generate a list of change orders, use this if you need to keep a record of changes made to a design file. If you click the Close button in the ECO dialog the changes will not be applied, so you will be returned to the Parameter Table Editor dialog.

11. Save the library.
17.2 Component Auditing

It is standard design practice to create and edit components during the design process. Altium Designer includes updating tools that give complete control over the updating process. Along with the flexibility of being able to make edits to a given instance of a component or footprint, also comes the risk of making edits that might not be correct or ideal. Altium Designer includes features to help check the schematic symbols and PCB footprints against the libraries they came from, and generate reports that show any differences.

17.2.1 Schematic Updating

Schematic components are updated using the Update from Libraries wizard in the schematic editor.

- Select Tools » Update From Libraries, to open the Update from Libraries wizard.
- The default is to do a full update on every component; including its graphical attributes, models and parameters (the designator is not changed).
- To control what attributes of the components are to be updated, uncheck the Fully replace symbols on sheet with those from library setting.
- The Advanced button provides greater flexibility in terms of how parameter and model difference should be handled.

![Update from schematic library to schematic](image)

**Figure 8. Update from schematic library to schematic**
Updates are performed through the ECO system, and a report can be produced if needed.

The wizard checks each component against the original library it came from, if those libraries are not available, or if you need the update to be done from another library, those components will need to have their Library Name attribute disabled, allowing Altium Designer to search all available libraries instead. This attribute is configured in the Component Properties dialog.

If the update process creates more changes than expected, it is probably due to component customization that has been performed after the component was placed. For example, a generic discrete component being given a value after it was placed. Use the Advanced options in the wizard to control parameter updates.

When the component in the library is unique, for example the resistor's value, footprint and other parameters are fully specified; any detected difference should be carefully checked. When in doubt avoid wholesale updates of all components in the project, instead selectively enable only those components you are currently working on.

Note: It is also possible to update schematic components from the library editor, onto currently open schematic sheets. This is a very basic update feature which does a complete replacement of the component — the only attribute retained from the instance placed on the schematic sheet is the designator value.

Note: To compare components placed from one library with those placed from another, use the Parameter Manager. Pre-select components of interest, then enable the Selected Objects Only checkbox in the initial Parameter Editor Options dialog that appears when you select Tools » Parameter Manager.
PCB footprints can be updated directly from the PCB library, think of this as *pushing* the footprint from the library onto the board. Footprints can also be updated from the board, using the Update From Libraries tool, which can be thought of as *pulling* the footprints from the libraries onto the board.

- Push-type updating is limited; it can only be done one library at a time, for one footprint or all footprints in that library.
- Pull-type updating is fully configurable; it does a detailed comparison between all primitives in every footprint on the board and the footprints in the library, and can also produce a detailed report. This updating is done by selecting **Tools » Update from PCB Libraries** from the PCB editor menus.

The PCB footprint libraries need to be available to perform an **Update from PCB libraries**. The library specified in the PCB editor **Component** dialog is the library that the footprint was placed from when the design was initially transferred.

Before the update dialog opens an options dialog appears, where you can set the tolerance, and layers to include. The default settings should suit most situations, however if you are working on a legacy design from another design system you may need to adjust the tolerance to avoid showing insignificant differences.
• You may not need to include all layers in the comparison. For example, if you have adjusted the widths of the overlay to suit the current design, you can disable the overlay layers.
• The Create Report button produces a detailed HTML report.

**Note:** Keep in mind that certain footprint properties, such as solder mask and paste mask expansions, can be defined manually for each footprint (in the library or on the board), or they can be controlled via design rules. Manually defined attributes have the highest priority, so changes made in the library or on the board will override design rule settings for calculated fields such as these.

**Note:** Although it is possible to edit the footprint directly on the board (by unlocking the component primitives), the most common cause of difference is when the footprint has been placed from the wrong library, or has become out of date due to changes to the footprint at the library level. Differences should be considered carefully, and once an update has been performed a Batch DRC should be run to confirm the changes did not affect the integrity of the PCB layout.

### 17.2.3 Other Audit techniques

#### 17.2.3.1 Reviewing changes to Documents

The file comparison tools in the Storage Manager provide an excellent way of reviewing changes made to a file.

• Comparisons can be made between the current file and an older version saved by Altium Designer’s built-in **Local History** system, or between the current version and an older version stored in your version control system.
• Comparisons can be done between different revisions of the same document or comparing two documents from different projects.

![Comparison using Storage Manager](image)

*Figure 13. Using the Storage Manager to compare two different revisions of the same schematic document. The difference panel details all of the differences found, double click to display the affected objects.*
17.2.4 Exercise – Using the new component in schematic

1. Open Sensor.schdoc.
2. Select the command **Tools » Update from Libraries**.
3. We are interested in updating not only the TCN75 component, but also the other components from the temperature sensor.schlib, as there have been other parameters and model changes. In the **Update from Library** wizard, set the checkboxes so that only components from the *Temperature sensor.schlib* are updated. Set the update Actions to only update models and parameters, using the checkboxes down the bottom left of the wizard.

![Update from Library wizard](image)

4. Click **Next** and confirm that the components are being updated from the correct library.

5. Click the **Finish** button to create the ECOs needed to update the selected component model and parameter data, and **Execute** the ECOs to make the changes.

6. Once the update is complete, right-click on the TCN75 symbol, and select **References » Help** from the floating menu. This should open the PDF document that was linked in the Exercise – adding a component parameter. Note that this link can also be pressing **F1** when the cursor is over the TCN75 component.

7. Save all the schematic sheets.
8. Since a new component has been added, we need to update the PCB. Select the **Design » Update PCB** command from any schematic document.
9. Since a new component has been added, it should first detect unmatched component classes, if component classes exist on the board. If the Match Manually dialog appears, click Yes and continue with step 10. If it does not appear, go straight to step 11.

10. In the Match Component Classes dialog, select Sensor in both of the Unmatched columns, and click the arrow to match them. Click Continue.

11. Since a NetClass called Power was created in Module 12 - Design Rules, you will need to disable the change to Remove Net Classes (Power) in the Engineering Change Order dialog.

12. Validate and Execute the remaining changes to add the new SOIC8 footprint to the PCB, close the ECO dialog, and position the SOIC8 on the board. If you find the Add Pins to Nets ECOs do not validate, run the Update process again.

Note: To prevent that NetClass being removed by future updates, you can go to the Comparator tab in the Project Options dialog and disable the checking for Extra Net Classes.
17.3 3D PCB Components

Given that many boards must fit into unusually shaped and tight-tolerance housings, it is a common requirement that the loaded board be transferred to an M-CAD system.

- With the introduction of 3D visualization in Altium Designer 6 it became possible to display the board in 3D within the PCB editor, and export the board as a STEP format file.
- You can also import STEP models into footprints in the PCB library, creating a complete E-CAD to M-CAD 3D solution.
- Component shapes can be modeled using Altium Designer’s 3D body objects, or by importing a STEP format component model. Both types of models export into the board STEP file.
- Alignment tools are included to orient the STEP model with the footprint.

![Figure 14. The completed board can be displayed in a highly realistic 3D view, and then exported.](image)

**Note:** 3D visualization requires a graphics card that supports DirectX 9 (or better), and Shader Model 3 (or better).

17.3.1 Using Altium Designer’s 3D Body Objects

3D body objects can be used to model a component’s shape. They are ideal when there is no STEP model available, or you do not need a precise shape for a particular component.

- Complex component shapes can be built up by placing multiple body objects onto a mechanical layer. Use the **Place » 3D Body** command in the PCB library editor.
- Shapes can be placed manually, or using the **3D Body Manager**. The **3D Body Manager** (Library editor **Tools** menu) is an ideal way of creating initial shapes, which can then be modified and supplemented by manually placed 3D bodies.
- Use the **2** and **3** shortcut keys to toggle the library editor display between 2D and 3D modes.
- The **PCBLib List** panel is ideal for reviewing the 3D body objects in a footprint, and editing their height and color settings. This can be done with the footprint displayed in either 2D or 3D, if it is in 3D mode the changes can be examined immediately.
17.3.2 Importing a 3D STEP Model

STEP is a popular data exchange format, supported by all the major M-CAD packages. There are different versions of the STEP format, including 203 and 214. Note that the 203 format does not support color information, models in this format will display in Altium Designer in a pale grey color.

- STEP format component models are imported into an Altium Designer 3D body object, using the Place » 3D Body from STEP Model command.
- Use the 2 and 3 shortcut keys to toggle the library editor display between 2D and 3D modes.
- You will often find the STEP model has been built using a different orientation than the Altium Designer footprint; there are a number of orientation and alignment tools to help resolve this.
- While they may have different orientations, STEP models often have the same origin as the PCB footprint. Adding a snap point to the model’s origin can help aligning them, the easiest way to do this is in the 3D Body dialog (double click on the Body object containing the imported STEP model), and click the Add button.
17.3.3 Rotating and Positioning the STEP model

Figure 17. Use the Inspector to test different rotation values.

- The Inspector panel is ideal for experimenting with rotation values while the footprint is in 3D view mode.
- Use the M, M shortcuts to move the STEP model, click on the model origin as the holding point.
- Use the J, R shortcuts to jump to the footprint reference point while the STEP model is being moved, press Enter to place it.
- STEP models can also be rotated using the numeric keypad as the model is being moved. Press 2 & 8 for X axis rotation, 4 & 6 for Y axis, and Spacebar & Shift+Spacebar for Z Axis. These shortcuts are detailed in the Shortcuts panel (when the model is being moved).
- Any number of snap points can be added to the model, to facilitate moving and aligning it with the footprint. Use the interactive commands in the Tools » 3D STEP Body Placement submenu to do this (available when the footprint is 3D view mode).
- The Add Snap Point from Vertices command has 2 modes: use it to add a snap point on the chosen vertex, or press the Spacebar to toggle to the midpoint mode, where the snap point is added midway between the 2 vertices you click on. This mode is ideal for adding snap points to the center of component pins. Keep an eye on the Status bar for details.

Note: as well as component manufacturer websites, 3D models can be downloaded from http://www.3dcontentcentral.com/. Try multiple different search strings to get the best results.

17.3.4 Exercise – importing a STEP model

In this exercise we will import a STEP model for the power jack that has been downloaded from the 3DContentCentral website.
1. Open the Temperature Sensor.PcbLib, and select the footprint PWR2.5.

2. Make Mechanical 1 the active layer.

3. Select **Place » 3D Body** from the menus, and in the **3D Body** dialog:
   - set the **3D Model Type** to **Generic STEP Model**,  
   - then click the **Embed STEP Model** button,  
   - then in the **Choose Model** dialog, navigate to the folder \Altium Designer Summer 09\Examples\Training\PCB Training\Temperature Sensor\Libraries\3D Models, and select the model **power_jack.step** and click **Open** to close the **Choose Model** dialog  
   - then click **OK** to close the **3D Body** dialog.

4. A box will appear floating on the cursor, position it anywhere just off to the right of the footprint.

5. The **3D Body** dialog will re-appear, click **Cancel** to close it.

6. Press the 3 shortcut to display the footprint in 3D mode and use **Shift + Right Mouse Button** to rotate the model slightly.

   **Note:** 3D visualization requires DirectX 9 and Shader Model 3 graphics card support.

7. Press L to open the **View Configuration** dialog. In the dialog, enable both the **Show Simple 3D Bodies** and **Show STEP Model** options. Use the **Save As View Configuration** option to save these settings as your own view configuration. This will now be available in the drop down list of configurations at the top of the PCB workspace.

8. The model will have a different orientation to the footprint, as shown in Figure 16. Before attempting to re-orient it, we will add a Snap Point to the model origin. To do this, double click on the upper-most face of the model to open the **3D Body** dialog. Click the **Add** button to add a Snap Point, and **OK** to close the dialog.

9. To re-orient the model using the Inspector panel, press F11 to open the panel. If the panel is blank click once on the model to select it, loading its attributes into the Inspector.

10. Experiment with different values in the Model Rotation fields (as shown in Figure 17). Keep in mind that you are rotating around the axis that you are editing.

11. Once the model has the correct orientation (Model Rotation X=90, Model Rotation Y=0, Model Rotation Z=270), it is time to re-position it on top of the footprint. To do this press M, M to run the Move Object command, the cursor will change to blue.

12. We want to pick the model up by the snap point at its origin, which is indicated by the cross hair on the front face. Be careful as you click to select this point, you can pick up a model by any default vertex, or by any user-defined snap point. Since there is a default vertex at the mid-point of every edge, you may find that when you click you are holding the model by the vertex that is just next to the snap point. Zoom in (**Ctrl+roll**) to confirm that you are holding it by the snap point.

13. Once you are moving the model by the snap point, let go of the mouse, press J, R on the keyboard to jump to the footprint reference, and press Enter on the keyboard to position the model. If you turn the footprint+model over (**Shift + Right Mouse Button**) you will see that the component pins are centered in the footprint pads. Once positioned, press Esc or click **Right Mouse Button** to drop out of the Move Object command, the cursor will change from blue back to orange.

14. To update the footprint on an open PCB, right-click on the footprint name in the PCB Library panel, and select **Update PCB With PWR2.5**.
17.4 Library Package types

The Schematic PCB libraries have been created, and all the models have been linked to the schematic library components. If required, we are now at the stage were we can link everything together and create a single library. There are different ways this can be done in Altium Designer, each with its own advantages. Possible library options include:

- Separate schematic and PCB libraries
- an integrated library, or IntLib – a single compiled library that is, compact, secure and portable
- A Database library, or DBLib – interfaces to your company component database
- An extension to the database library, called a Subversion database library – interfaces to a component database, and subversion, a free version control system.

For this course we are only going to cover Integrated libraries. For database libraries and SVN database libraries refer to the Advanced PCB course for more information.

17.4.1 Integrated Libraries

An integrated library is actually the compiled output from a Library Package. The Library Package is essentially a project file for libraries.

- To create a new library package, select File » New » Project » Integrated Library from the menus.
- Source schematic and PCB libraries can be added to the new library package by dragging and dropping them in the Projects panel. Hold Ctrl as you drag and drop if you want to have the source libraries in both the PCB project and the library package.
- To compile the Library Package and create the Integrated Library, right click on the library package in the Projects panel and select Compile Integrated Library from the floating menu.
- The compilation process checks that all specified models are available and the linking between symbol and model pins. Check the Messages panel for any compilation Warnings or Errors.
- Even if you choose not to deploy and use the compiled integrated library, compiling is an excellent way of checking the mapping between each symbol and its various models.
- Integrated libraries are also very compact, usually 1/8 to 1/10 the size of the original documents.
- Updating components in a design from Integrated Libraries is faster.
- An integrated library can be placed on a network drive and used throughout your company.
- Although the integrated library is compiled, the source libraries can be extracted if necessary. When you attempt to open an Integrated Library (like a file, instead of installing it in the Libraries panel like a library), you will be asked if you wish to extract the sources, as shown in Figure 19.
- Only source schematic and PCB library files are added into the created library package as source files.
All other model kinds, such as simulation MDL and CKT files, are extracted, you will find them in the same folder as the extracted symbols and footprints. They are included in the project using a Search Path, defined in the Project Options for the library package.

Figure 19. Result of extracting the contents of the integrated library, Miscellaneous Devices.
17.5 Library Reports

There are several reports available in both the Schematic Library Editor and Schematic Editor that are used to record component, library and project information, such as a Bill of Materials (BOM).

17.5.1 Library Editor Reports

There are three reports that can be generated in the Library Editor. All have the syntax `Library_Filename.extension`.

- The `Reports » Component` command generates a `.CMP` file that includes the component name, part count, components in the same group, details of each part and details of all pins. This report can be used to verify that the component has been correctly constructed.

- The `Reports » Library List` command generates a `.REP` file which includes a component count as well as the name and description of each component in the library. This report can be used to create a listing of the components in a library, handy if you need a printed reference of a library.

- The `Reports » Component Rule Check` command opens the `Library Component Rule Check` dialog (Figure 20). These allow you to test for:
  - duplicate component names and pins
  - missing description
  - missing footprint
  - missing default designators
  - missing pin name
  - missing pin number
  - missing pins in sequence.

Running this generates a `.ERR` report which reports on all components in the active library. This report can be used to aid in library verification and library management.
The **Report » Library Report** command presents the Library Report Settings, which allows you to generate either a Microsoft Word® document, or an HTML document. An example report is shown in Figure 21.

**Figure 21. Library report, and the Library Report Settings dialog**

**Note:** You can also generate a library report from the Libraries panel. Right-click on a component in the panel and select **Library Report** from the context menu.