Module 3: Schematic Editor Basics

3.1 Schematic Editor basics ................................................................. 3-1
  3.1.1 View Commands ......................................................................... 3-2

3.2 Schematic graphical objects ......................................................... 3-4
  3.2.1 General ..................................................................................... 3-4
  3.2.2 Drawing schematic graphical objects ........................................... 3-4

3.3 Schematic electrical objects ............................................................ 3-9
  3.3.1 General ..................................................................................... 3-9
  3.3.2 Summary of Electrical Objects ................................................... 3-9
  3.3.3 Exercise – Schematic graphical objects ....................................... 3-19
  3.3.4 Exercise – Schematic electrical objects ....................................... 3-19
  3.3.5 Favorites Panel .......................................................................... 3-19
  3.3.6 Snippets Panel .......................................................................... 3-20
  3.3.7 Clipboard panel ......................................................................... 3-20
  3.3.8 Selection ................................................................................... 3-21
  3.3.9 Masking ................................................................................... 3-23
  3.3.10 Other mouse actions ................................................................. 3-24
  3.3.11 Multiple objects at the same location ......................................... 3-24
  3.3.12 Smart Paste ............................................................................ 3-24
  3.3.13 Modifying Polylines ................................................................. 3-26
  3.3.14 Font Management ................................................................. 3-27
  3.3.15 Exercises – Schematic Editor basics ......................................... 3-27

Software, documentation and related materials:

Copyright © 2009 Altium Limited.

All rights reserved. You are permitted to print this document provided that (1) the use of such is for personal use only and will not be copied or posted on any network computer or broadcast in any media, and (2) no modifications of the document is made. Unauthorized duplication, in whole or part, of this document by any means, mechanical or electronic, including translation into another language, except for brief excerpts in published reviews, is prohibited without the express written permission of Altium Limited. Unauthorized duplication of this work may also be prohibited by local statute. Violators may be subject to both criminal and civil penalties, including fines and/or imprisonment. Altium, Altium Designer, Board Insight, Design Explorer, DXP, LiveDesign, NanoBoard, NanoTalk, P-CAD, SimCode, Situs, TASKING, and Topological Autorouting and their respective logos are trademarks or registered trademarks of Altium Limited or its subsidiaries. All other registered or unregistered trademarks referenced herein are the property of their respective owners and no trademark rights to the same are claimed.

Module Seq = 3
3.1 Schematic Editor basics

The Schematic Editor opens when you open an existing schematic document or create a new one. This editor makes use of all the workspace features in the Altium Designer environment. This includes multiple toolbars, resource editing, right-click menu, shortcut keys and Tool Tips.

Figure 1. Schematic Editor Workspace

In this section, we will explore the basics of working in the Schematic Editor.

- If not already open, open the following project: 4 Port Serial Interface.PrjPcb, found in the Altium Designer Summer 09\Examples\Reference Designs\4 Port Serial Interface folder (as shown above in Figure 1), and then open the schematic sheet, ISA Bus and Address Decoding.SchDoc by double-clicking on the document name in the Projects panel.
### 3.1.1 View Commands

The View commands can be accessed from the View menu and are listed below.

<table>
<thead>
<tr>
<th>Command</th>
<th>Toolbar</th>
<th>Shortcut Key</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fit Document</td>
<td></td>
<td>VD</td>
<td>Display entire document</td>
</tr>
<tr>
<td>Fit All Objects</td>
<td></td>
<td>VF</td>
<td>Fits all objects in the current document window</td>
</tr>
<tr>
<td>Area</td>
<td></td>
<td>VA</td>
<td>Display a rectangular area of document by selecting diagonal vertices of the rectangle</td>
</tr>
<tr>
<td>Around Point</td>
<td></td>
<td>VP</td>
<td>Display a rectangular area of document by selecting the centre and one vertex of the rectangle</td>
</tr>
<tr>
<td>Selected Objects</td>
<td></td>
<td>VE</td>
<td>Fits all selected objects in the current document window</td>
</tr>
<tr>
<td>50%</td>
<td></td>
<td>V5</td>
<td>Set display magnification to 50%</td>
</tr>
<tr>
<td>100%</td>
<td></td>
<td>V1</td>
<td>Set display magnification to 100%</td>
</tr>
<tr>
<td>200%</td>
<td></td>
<td>V2</td>
<td>Set display magnification to 200%</td>
</tr>
<tr>
<td>400%</td>
<td></td>
<td>V4</td>
<td>Set display magnification to 400%</td>
</tr>
<tr>
<td>Zoom In</td>
<td></td>
<td>VI</td>
<td>Zoom In around current cursor position</td>
</tr>
<tr>
<td>Zoom Out</td>
<td></td>
<td>VO</td>
<td>Zoom Out around current cursor position</td>
</tr>
<tr>
<td>Pan</td>
<td></td>
<td>VN</td>
<td>Re-centre the screen around current cursor position</td>
</tr>
<tr>
<td>Refresh</td>
<td></td>
<td>VR</td>
<td>Update (redraw) the screen display</td>
</tr>
</tbody>
</table>

*Table 1. View command summary*

While executing a command (when a crosshair is attached to the cursor), auto panning becomes active by touching any edge of the Design Window. Press the SHIFT key while auto panning to increase the panning speed. Auto panning speed is configured in the Auto Pan Options section of the Graphical Editing page in the Preferences dialog (Tools » Schematic Preferences). Auto panning can also be turned off here.

**Note**: The auto pan options apply in both the schematic and the schematic library editors. Since you work at a much higher zoom level in the library editor window area, you may find that auto panning moves the view too quickly. If this is the case you may prefer to disable auto panning and pan with the right mouse button (refer to 3.1.1.2).
The following shortcut keys provide a useful alternative for manipulating the view of the workspace. These shortcut keys can be used while executing commands.

<table>
<thead>
<tr>
<th>Keystroke</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>END</td>
<td>Redraws the view</td>
</tr>
<tr>
<td>PAGE DOWN</td>
<td>Zoom out (holds the current cursor position)</td>
</tr>
<tr>
<td>PAGE UP</td>
<td>Zoom in (holds the current cursor position)</td>
</tr>
<tr>
<td>CTRL+PAGE DOWN</td>
<td>View Document</td>
</tr>
<tr>
<td>HOME</td>
<td>View pan (pan to centre the current cursor position)</td>
</tr>
<tr>
<td>SPACEBAR</td>
<td>Stops screen redraw</td>
</tr>
<tr>
<td>ARROW KEYS</td>
<td>Moves the cursor by one snap grid point in direction of the arrow</td>
</tr>
<tr>
<td>SHIFT+ARROW KEY</td>
<td>Moves the cursor by 10 snap grid points in the direction of the arrow</td>
</tr>
</tbody>
</table>

Table 2. Shortcut keys for view manipulation

3.1.1.1 Using the mouse wheel to pan & zoom

The mouse wheel can also be used to pan and zoom when in a design document.

**Panning**

Roll the mouse wheel upwards to pan upwards, and downwards to pan downwards.
Press SHIFT and roll the mouse wheel downwards to pan to the right.
Press SHIFT and roll the mouse wheel upwards to pan to the left.

**Zoom In**

Press CTRL and roll the mouse wheel upwards to zoom in.

**Zoom Out**

Press CTRL and roll the mouse wheel downwards to zoom out.

3.1.1.2 Using the right mouse button to pan

Click and hold down the right mouse button (RMB) and move the cursor to pan in a design document. The hand-shaped cursor indicates you are in panning mode. Release the right mouse button to stop panning.
3.2 Schematic graphical objects

3.2.1 General

- Use the Drawing Tools available on the Utilities toolbar to place the graphical objects. Turn the Utilities toolbar on and off by selecting View » Toolbars » Utilities.
- Drawing toolbar functions can also be accessed through the Place » Drawing Tools menu, except for Paste Array (Edit » Smart Paste).
- When placing an item, press the tab key to edit its properties. Double-click on a placed object to modify its properties.
- When an object is selected, its handles are displayed.
- While in a command, you can select another command, without quitting the first command, provided you use a shortcut key. This powerful feature, called re-entrant editing, will considerably enhance your productivity.

3.2.2 Drawing schematic graphical objects

For an example of each graphical object, open Graphical Objects.SchDoc found in the Altium Designer Summer 09\Examples\Training\PCB Training\Practice Documents folder.

![Schematic graphical objects](image)

*Figure 2. Schematic graphical objects*
The placement of each of these objects is described in the following sections.

### 3.2.2.1 Lines
To draw a line:

1. Select the **Place Line** toolbar button or **Place » Drawing Tools » Line**.
2. Click once to start the line.
3. Click to place each vertex. The BACKSPACE key deletes the last vertex placed.
4. Right-click once to end the line.
5. Right-click again to end the command.

### 3.2.2.2 Polygons
To draw a polygon:

1. Select the **Place Polygon** toolbar button or **Place » Drawing Tools » Polygon**.
2. Click to place each vertex.
3. Right-click to end the polygon.
4. Right-click again to end the command.
5. Turn the **Draw Solid** option off in the Polygon dialog to draw a polygon that is not filled.

**Note**: The fill color and border color of polygons are independent.

### 3.2.2.3 Arcs
To place a circular arc:

1. Select the **Place » Drawing Tools » Arc** menu command.
2. Click to place the arc centre.
3. Click to determine the arc radius.
4. Click to place the start of the arc and click to place the end of the arc.
5. Right-click to end the command.

### 3.2.2.4 Elliptical arcs
To place an elliptical arc:

1. Select the **Place Elliptical Arc** toolbar button or **Place » Drawing Tools » Elliptical Arc**.
2. Click to place the arc centre.
3. Click to determine the arc X-radius.
4. Click to determine the arc Y-radius.
5. Click to place the first end of the arc and click to place the second end of the arc.
6. Right-click to end the command.
3.2.2.5 Bezier curves

A Bezier curve is a curve of best fit between points defined by mouse clicks.

To draw a Bezier curve:

1. Select the **Place Bezier Curve** toolbar button or **Place » Drawing Tools » Bezier**.
2. Click once to place the first control point at the start of the curve.
3. Click to place the second control point.
4. Click to place the third and fourth control points.
5. Continue to click to place further control points.
6. Right-click to end the command.
7. To reshape the curve, click on one end of the curve and then move, add (INSERT key) or delete new control points (handles).

3.2.2.6 Annotation (Text)

To place a line of text:

1. Select the **Place Annotation** toolbar button or **Place » Annotation**.
2. Press **Tab** to edit the contents and the font of the text. You can add special strings from the Text drop-down list as well, such as the date and document information. This topic is covered in more detail in the *Schematic Capture* training session.
3. Click to position the text.
4. Right-click to end the command.

Text strings can also be edited by selecting the string and clicking again to highlight the text.

3.2.2.7 Text frames

Text frames are used to place paragraphs of text on the sheet.

To place a text frame:

5. Select the **Place Text Frame** toolbar button or **Place » Text Frame**.
6. Press **Tab** to edit the contents and properties for the text frame and click **OK**.
7. Click to position the top left corner of the frame and then click to position the bottom right corner of the frame.
8. Right-click to stop placing text frames.

The following keys apply when entering text into the frame:

<table>
<thead>
<tr>
<th>Action</th>
<th>Keystroke</th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert a tab</td>
<td>CTRL+TAB</td>
</tr>
<tr>
<td>Cut</td>
<td>SHIFT+DELETE or CTRL+X</td>
</tr>
<tr>
<td>Copy</td>
<td>CTRL+INS or CTRL+C</td>
</tr>
<tr>
<td>Paste</td>
<td>SHIFT+INS or CTRL+V</td>
</tr>
</tbody>
</table>

*Table 3. Text Frame action summary*

The Cut, Copy and Paste commands apply to the Windows clipboard. The clipboard can also be used to bring text in from other applications.
3.2.2.8 Notes

Notes are used to place paragraphs of text on the sheet that can be collapsed and expanded at will.

To place a Note:

1. Select **Place » Notes » Note** or **PEO** shortcut.
2. Press **Tab** to edit the contents and properties for the Note and click **OK**.
3. Click to position the top left corner of the Note and then click to position the bottom right corner of the frame.
4. Right-click to stop placing Notes.

The following keys apply when entering text into the frame:

<table>
<thead>
<tr>
<th>Action</th>
<th>Keystroke</th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert a tab</td>
<td>CTRL+TAB</td>
</tr>
<tr>
<td>Cut</td>
<td>SHIFT+DELETE or CTRL+X</td>
</tr>
<tr>
<td>Copy</td>
<td>CTRL+INS or CTRL+C</td>
</tr>
<tr>
<td>Paste</td>
<td>SHIFT+INS or CTRL+V</td>
</tr>
</tbody>
</table>

*Table 4. Note action summary*

The Cut, Copy and Paste commands apply to the Windows clipboard. The clipboard can also be used to bring text in from other applications.

5. Notes can also be collapsed and expanded by clicking on the small up arrow that is in the top left hand corner of the note.

3.2.2.9 Rectangles

To place a rectangle:

1. Select the **Place Rectangle** toolbar button □ or **Place » Drawing Tools » Rectangle**.
2. Click to place top left corner.
3. Click to place bottom right corner.
4. Right-click to end the command.

3.2.2.10 Rounded rectangles

Rounded rectangles are rectangles with rounded corners. The radius of the arcs at the rectangle corners is set in the X-Radius and Y-Radius fields in the **Round Rectangle** dialog.

To place a rounded rectangle:

1. Select the **Place Rounded Rectangle** toolbar button □ or **Place » Drawing Tools » Rounded Rectangle**.
2. Press **Tab** to set the corner radii and click **OK**.
3. Click to place top left corner and click to place bottom right corner.
4. Right-click to end the command.

3.2.2.11 Ellipses

Use this command to draw circles as well. To place an ellipse:
1. Select the **Place Ellipse** toolbar button or **Place » Drawing Tools » Ellipse**.
2. Click to place the ellipse centre.
3. Click to determine the ellipse X-radius.
4. Click to determine the ellipse Y-radius.
5. Right-click to end the command.

### 3.2.2.12 Pie charts
To place a pie shape:

1. Select the **Place Pie Chart** toolbar button or **Place » Drawing Tools » Pie Chart**.
2. Click to place the pie centre.
3. Click to determine the pie radius.
4. Click to place the first edge of the pie and click to place the second edge.
5. Right-click to end the command.

### 3.2.2.13 Graphic images
Graphic images with the following formats can be added to your schematic:

- .bmp, .rle, .dib
- .jpg, .tif (uncompressed)
- .wmf, .pcx, .dcx, .tga.

The file containing the graphical image can be embedded into the sheet or linked. If the image file is linked it must be transferred with the schematic file when moving the schematic from one location to another.

To place a graphic image:

1. Select the **Place Graphic Image** toolbar button or **Place » Drawing Tools » Graphic**.
2. Click to place the top left corner of the image and click to place the bottom right corner of the image.
3. Locate the file that contains the image and click **OK**.
4. To embed the image, double click on it to open the Graphic dialog and enable the **Embedded** option.

**Note:** The advantage of embedding the image into the schematic or schematic template is that the image will still be visible if the file is moved. The disadvantage is that the schematic file size will be larger.
3.3 Schematic electrical objects

3.3.1 General

Schematic electrical design objects define the physical circuit you are capturing. Electrical objects include components (parts) and connective elements, such as wires, buses and ports. These objects are used to create a netlist from the schematic, which is then used to transfer circuit and connection information between design tools.

- Use the Wiring toolbar to place electrical objects.

Figure 3. Schematic electrical objects

- All Wiring Tools toolbar functions can be accessed through the Place menu.
- Text in electrical objects can be over scored, typically to indicate an active low signal, by adding ‘\’ after the character, e.g. R\ESET would display ‘R’ as over scored text. To overscore the entire word with a single ‘\’ character, enable the Single ‘\’ Negation option in the Schematic – Graphical Editing page of the Preferences dialog.

In the following sections, the use of each electrical object is explained.

3.3.2 Summary of Electrical Objects

For an example of each electrical object, open Electrical Objects.SchDoc found in the Altium Designer Summer 09\Examples\Training\PCB Training\Practice Documents folder.
3.3.2.1 Wires

- Select the **Place Wire** toolbar button or **Place » Wire**.
- Wires are used to represent an electrical connection between points.

**Note:** Be careful to use the **Place » Wire** command, and not use the **Line** command by mistake.

- Press the **shift + SPACEBAR** to change the placement mode. There are Four placement modes as follows:
  - 90 degree
  - 45 degree
  - any angle
  - auto wire.
- The **BACKSPACE** key deletes the last vertex placed.
- The **SPACEBAR** is used to change the current placement modes start and end point. This only works for 90 and 45 degrees modes.
- A wire end must fall on the connection point of an electrical object to be connected to it. For example, the end of a wire must fall on the hot end of a pin to connect.
- Wires have the Auto Junction feature, which automatically inserts a Junction object if a wire starts or ends on another wire or runs across a pin.
- To add more vertices click and hold the left mouse button on a wire and press the **INSERT** Key.
- To remove a vertex, select the vertex, right click and select **Edit Wire Vertex NO.** Wire properties dialog comes up in vertices mode and click **Remove**.

3.3.2.2 Buses

- Buses are used to graphically represent how a group of related signals, such as a data bus, is connected on a sheet. They are also used to collect together all the signals belonging to a bus on a sheet and connecting them to a port to enter or leave a sheet. In this instance, they must have a net label of this format: D[0..7].
- Select the **Place Bus** toolbar button or **Place » Bus**. Place a bus line in the same manner as placing wires, i.e. press **SPACEBAR** to change placement mode and press the **BACKSPACE** key to delete the last vertex placed.
- Buses can only represent connections to ports and sheet entries and only at their end points.
- The same shortcut commands used for wire mode apply to the Bus placement mode.

3.3.2.3 Bus Entries

Bus entries are used to represent a connection between a wire and a bus.

To place a bus entry:

1. Ensure that an appropriate snap grid is set so that connections will be made.
2. Select the **Bus Entry** toolbar button or **Place » Bus Entry**.
3. Press the **SPACEBAR** to rotate the bus entry.
4. Click once to position the bus entry.
5. Right-click to stop placing bus entries.

**Note:** The use of bus entries is optional. Many users prefer to place a 45-degree wire.
3.3.2.4 Signal Harness

Wires are used to represent an electrical connection between points. Buses are used to represent a group of related signals, which are identified by a specific naming convention.

Signal Harnesses allow the logical grouping of multiple signals, including wires, buses and other signal harnesses. This group can be treated as a single entity, which can be used across the entire project.

There are 4 key elements to a Signal Harness system:

- Signal Harness
- Harness Connector
- Harness Entry
- Harness Definition File

![Figure 4. A Signal Harness can carry any combination of wires, buses and other signal harnesses.](image)

**Note:** Hover the mouse over a harness to detail all contained nets, buses and sub-harnesses.

3.3.2.5 Harness Connector

This object is used to group together the various signals that form a Signal Harness. The harness connector will include a harness entry for each net, bus and sub-harness being bundled into the Signal Harness.

![Figure 5. The Harness Connector groups the signals in the Signal Harness. It is defined by the Harness Type, which in this example is I2S](image)

**Note:** Use the Smart Paste command to convert selected Net Labels into Harness Connectors.
3.3.2.6 Harness Entry

For a net, bus or sub-harness to be included in a Signal Harness, it must connect to a Harness Entry in a Harness Connector.

![Harness Entry Diagram](image)

*Figure 6. The Harness Entries provide the connection point for each of the nets feeding into the Signal Harness. In this case, the Harness Entries are WCLK, BCLK, DOUT, DIN and MCLK*

3.3.2.7 Harness Definition

For each Signal Harness included in a design, there is a Harness Definition file. Each Harness Definition comprises of a Harness Type (I2S in the image below), and the related Harness Entries (in this case: BCLK, DIN, DOUT, MCLK, WCLK).

The Harness Definition files (*.Harness) are created and managed automatically by Altium Designer. Harness Definition Files appear in the Projects panel under the Settings\Harness Definition Files sub-folder.

![Harness Definition Files](image)

*Figure 7. The Harness Definition Files are text files that are located under Settings in the Projects Panel. These contain textual representations of Signal Harnesses and their respective Harness Entries. They can be identified by their extension *.Harness*

**Note:** It is possible to create a Signal Harness without the Harness connector. In this case the Harness Definition file must be created and managed manually.
3.3.2.8 Net Labels

- A net label is used to make a net easily identifiable and also provides a method of connecting pins belonging to the same net without placing a wire.
- A connection is made between all wires with identical net labels on a sheet. In some cases, all wires with identical net labels in a project will be connected together. Hierarchies will be explored in more detail during the Schematic Capture training session.
- All net labels on a net must be identical.
- The net list generator will convert all net labels to upper case.
- To associate a net label with a wire, place it so that its reference point (bottom left corner) falls on the wire.
- The electrical grid is active when placing net labels.
- If the last character in a net label is a number, it will increment when subsequent net labels are placed.

To place a net label:
1. Ensure that an appropriate snap grid is set so that connections will be made.
2. Select the Place Net Label toolbar button or Place » Net Label.
3. Press Tab to edit the net label text. The Net Label dialog displays.
4. Click on the down arrow in the Net field to display the names of nets already defined on the sheet, or type in the new net name. Click OK.
5. Press spacebar to rotate the net label.
6. Click once to position the net label.
7. Right-click to stop placing net labels.

Note: During net label placement, hover the mouse over existing text on a schematic and press the Insert shortcut key, the net label will pick up that string value.
3.3.2.9 Power Ports

- All power ports with the same Net property in a project will be connected.
- To connect to a power port, make sure that a wire falls on the end of the power port pin.
- The style of the power port only changes its appearance. It does not affect the connectivity as this is established through the Net property.
- Power ports will connect to hidden pins with the same name throughout the design, regardless of the net identifier scope used.
- The Power Port buttons on the Wiring toolbar will only place a single power port. To change this behavior and place multiple ports, edit the button and add the parameter Repeat=True.

To place a power port:

1. Select either the GND or VCC Power Port toolbar buttons, or Place » Power Port.
2. Press TAB to edit the power port properties for a net name other than GND or VCC.

![Power Port dialog](image)

Figure 9. Power Port dialog

3. Click to position the port. Right-click to stop placing power ports.

3.3.2.10 Parts

- When Place » Part (PP) is selected or you click on the Place Part toolbar button, the Place Part dialog is displayed. You can enter the name of the component in the Lib Ref field or you can click on the Browse button (…) to locate the part by browsing and adding the required library.
• Parts can also be placed using the Place button in the Schematic Library Editor.
• When placing parts, use a snap grid that will cause the pin ends to fall on a grid point, e.g. 10. Press G to cycle through the snap grid settings of 1, 5 and 10.

3.3.2.11 Sheet Symbols
• Sheet symbols are used when you wish to break the design into a number of sheets.
• A sheet symbol must be placed for each schematic document in the project.
• The sheet symbol name is a descriptive name for the sheet.
• The sheet symbol filename must be the document name of the schematic document it represents. All sheets in a project should be in the same directory.
• When changing the size of the sheet symbol, make sure the edges of the sheet symbol fall on the snap grid to ensure connection between wires and sheet entries.

To place a sheet symbol:
1. Select the Sheet Symbol toolbar button or Place » Sheet Symbol (PS).
2. Press Tab to edit the sheet symbol name and sheet symbol file name.
3. Click to place the top left corner.
4. Click to place the bottom right corner.
5. Right-click to stop placing sheet symbols.

Note: Sheet symbols, complete with sheet entries, can be created using the command Design » Create Sheet Symbol From Sheet or HDL. The Synchronize Sheet Entries and Ports command (Design menu, or right-click on Sheet Symbol menu) can also be used to synchronize the entries on a sheet symbol to the ports on the sheet below. This is covered in Module 5 - Multi-Sheet Design.
3.3.2.12 Sheet Entries

- Sheet entries are used in the sheet symbols if you are doing the design in a true hierarchical structure, with nets interconnecting the sheet symbols.
- Each sheet entry needs a matching port on the sub-sheet.
- Use Sheet Symbols / Port Connections as the Net Identifier Scope when creating netlists or running the Electrical Rules Checker.

To place a sheet entry:

1. Select the Place Sheet Entry toolbar button or Place » Add Sheet Entry (PA).
2. Click on the sheet symbol that the sheet entry is for and the sheet entry symbol appears within the sheet symbol box.
3. Press Tab to edit the sheet entry properties.
4. Click on the down arrow in the name field to list all the Sheet Entry names used on the current sheet.
5. Position the sheet entry on any side of the sheet symbol and click.
6. Right-click to stop placing sheet entries.

Note: Altium Designer can insert sheet entries automatically, by enabling the Place Sheet Entries automatically option in the Graphical Editing page of the Preferences dialog. An entry is placed automatically when the wire is terminated on the edge of a sheet symbol, if the net currently being wired can be identified.

3.3.2.13 Ports

- Ports provide a method of forming connections from one sheet to another sheet.
- Click on the down arrow in the Name field to list all the Port names defined on the sheet.
- The port I/O Type is used by the ERC when checking for connection errors.
- The port style only changes the appearance of the port.

To place a port:

1. Select the Port toolbar button or Place » Port.
2. Press Tab to edit the port properties.

Figure 11. Port Properties dialog
3. Press the Spacebar to rotate or X and Y to flip.
4. Click to position one end of the port. Drag the mouse to set the port length and click to finish the port.
5. Right-click to stop placing ports.

**Note:** The Port Direction can be set automatically, based on the Port I/O type and where the wire touches the port. Enable the Port Direction option in the General page of the Preferences dialog.

### 3.3.2.14 Off Sheet Connectors

Off Sheet Connectors are used to connect nets across multiple schematic sheets that are descended from sheet entries of the same parent sheet symbol. To successfully connect a particular net across two or more sheets, the Off Sheet Connectors on each sheet must be assigned to the same net.

1. Select **Place » Off Sheet Connector (PC).**
2. Press **Tab** to edit the Off Sheet Connector properties.
3. Click to place the Off Sheet Connector. Right-click to exit placement mode.

**Note:** The primary function of Offsheet connectors is for translation to and from Orcad Schematic Capture. If you intend to use Altium Designer to draw up a schematic, but the end schematic is required in Orcad format, then Offsheet connectors can be used.

### 3.3.2.15 Junctions

- The software automatically adds an auto-junction at valid connection points, including T joins, and when a wire crosses the end of a pin. Auto-Junctions are not added at crossovers.
- Manual junctions can be used to force a junction at a crossover, select **Place » Manual Junction (PJ).** The crosshair cursor appears with a junction marker (red dot) on it. Click to place the junction marker.
- The Auto-Junction display is set in the Compiler page of the Preferences dialog.

### 3.3.2.16 Compile Mask

- A Compile Mask hides, or masks, all components and wiring underneath it, from the Altium Designer compiler. Clicking the small triangle in the upper left will collapse the Mask, returning those components and wiring to the circuit. Because they are masked from the compiler, those components are ignored during an update to PCB. Use Compile Masks to mask out sections of the design that are work in progress, to perform partial updates to the PCB, or to mask simulation sources (which are needed for simulation, but do not exist on the PCB).

To place a compile mask:

1. **Place » Directives » Compile Mask.**
2. Press Tab to edit the compile mask.
3. Click to place the top left corner.
4. Click to place the bottom right corner.
5. Right-click to stop placing compile masks.

### 3.3.2.17 No ERC Marker

- Placing a No ERC symbol on a node in the circuit suppresses any report warnings and errors that may be generated when compiling the schematic. These markers can also be suppressed for printing.
• Select the Place No ERC toolbar button or Place » Directives » No ERC. Click to place the No ERC marker on a pin or existing ERC marker. Right-click to exit placement mode.

3.3.2.18 Parameter Sets

Some objects do not support directly specifying parameters, such as wires and buses. To add a parameter to these attach a Parameter set object. PCB design rules can also be added to wires (nets) or buses using parameter set objects, these rule specifications are then passed to the PCB during synchronization.

1. Select Place » Directives » PCB Layout. The cursor appears with a directive symbol attached.

2. Press TAB to edit the PCB layout directive in the Parameters dialog. Edit in the parameters in the Parameters Properties dialog by clicking on the Edit button.

3. Click on the Edit Rule Values button.

4. Select a rule, click OK and set the values accordingly, and press OK. Keep pressing OK until all dialogs are gone.

5. Position the directives symbol so that its hot point (the end of the stem) touches the wire or bus. Click to place it.

6. Right-click to stop placing routing directives.

7. To add more than 1 rule to a directive, edit the directive and use the Add As Rule button.

Figure 12. The parameter set object is a container for adding parameters to objects, including PCB design rule definitions.

Note: PCB routing directives are Parameter Set objects. The separate menu entry to place PCB Routing Directives has been retained for user compatibility with earlier versions.
3.3.3 Exercise – Schematic graphical objects

1. Open Graphical Objects.SchDoc found in the Altium Designer Summer 09\Examples\Training\PCB Training\ Practice Documents folder and experiment with placing each of the drawing objects in the space provided.
2. Select each object and observe the handles.
3. Investigate the effect of moving handles.
4. Insert a new vertex into a polyline object, and then remove it.
5. Double-click on some of the objects to display and modify their properties.
6. Close the sheet without saving.

3.3.4 Exercise – Schematic electrical objects

1. Open Electrical Objects.SchDoc found in the Altium Designer Summer 09\Examples\Training\PCB Training\ Practice Documents folder and experiment with placing each of the schematic electrical objects.
2. Select each object and observe the effect of moving the handles.
3. Double-click on some of the objects to display and modify their properties.

3.3.5 Favorites Panel

Like a web browser, a list of favorite documents can be stored in this panel for future reference. A thumbnail of the view as well as title and comment is stored. For Altium Designer documents the zoom level and location is included.

Favourites can be tied to the project itself making it a useful mark up tool for design collaboration. Project favourites are stored in a ‘ViewsOf’ folder in the same folder as the project file.

- Open the Favourites panel from the panel controls down the bottom right by clicking on System » Favorites.
- The contents may be divided into folders. A new folder can be created from the right click menu.
- To add the current view to a folder use Add Current Document View from the right click menu.
- To recall a view simply double click the entry in the list.
- The size of the thumbnails is configured in the System preferences in the View section.

Figure 13. Favorites panel
3.3.6 Snippets Panel

The Snippets Panel provides a way to store portions of a design for later reuse. The panel will store sections of schematic, PCB layout and source code.

- Open the Snippets panel from the panel controls down the bottom right by clicking on **System » Snippets**

- The contents can be divided into folders. These are just regular Windows folders and the location can be configured from the Snippets Folders button. Multiple folders can be defined; using a shared network resource will let you share a snippets library amongst an entire design team.

- To create a snippet select the objects in the PCB, schematic, or code editor and then from the right click menu select **Snippets » Create Snippet from selection**. File the snippet away with a title and comments.

- To Place a snippet select it in the panel and then click the Place button at the top.

- If you reset selected component designators before using them to create a snippet, you can avoid duplicate designators when the snippet is placed.

3.3.7 Clipboard Panel

The Clipboard Panel provides a way of recalling earlier Copy actions. The panel stores copied sections of schematic, PCB layout and source code.

- Open the Clipboard panel from the panel controls down the bottom right by clicking on **System » Clipboard**

- The clipboard panel has the added advantage of being able to read the Windows clipboard, allowing data to be transferred from other programs into Altium Designer. To enable this, turn off the **Monitor clipboard content within this application only** option in the **Systems – General** page of the Preferences dialog.

- Clipboard panel data is only available for the current editing session, unlike the Snippets panel which stores data on the hard drive.
3.3.8 Selection

The Schematic Editor provides selection capabilities that are similar, although not identical, to selection in other Windows applications.

Below are some key points about selection in the Schematic Editor:

- The main use of selection is to nominate objects for a clipboard operation, i.e. which objects will be moved or copied to the clipboard when the Cut or Copy commands are invoked.
- Once objects are on the clipboard, they can then be pasted elsewhere onto the current schematic or into another schematic, or to another Windows application which supports the Windows clipboard.
- Selection is not cumulative. The selected object deselects when you click on another object.
- Hold the SHIFT key to select multiple objects.
- Press DELETE to delete all selected objects.

To select an object you can use:

<table>
<thead>
<tr>
<th>Keystroke</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Click and drag</td>
<td>Select all objects enclosed by drag area</td>
</tr>
<tr>
<td>SHIFT+click on object</td>
<td>Select an object (on a selected object, this will de-select it)</td>
</tr>
<tr>
<td>Edit » Select menu (S)</td>
<td>Select Inside Area, Outside Area, All, Net or Connection</td>
</tr>
<tr>
<td>Select Inside Area button on the Main toolbar</td>
<td></td>
</tr>
</tbody>
</table>

Table 5. Select command summary

Selected objects can be:

<table>
<thead>
<tr>
<th>Function</th>
<th>Keystroke</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cut, copied, pasted or cleared</td>
<td>Using the Edit menu commands</td>
</tr>
<tr>
<td>Moved</td>
<td>Click-and-hold on any selected object</td>
</tr>
<tr>
<td>Moved or dragged</td>
<td>Using the Edit » Move menu commands (M)</td>
</tr>
<tr>
<td>Aligned</td>
<td>Using the Edit » Align menu commands (A)</td>
</tr>
<tr>
<td>Deleted</td>
<td>Using DELETE</td>
</tr>
</tbody>
</table>

Table 6. Selected object command summary

Note: Selection in earlier versions of Altium software differed from other Windows applications in that selection was persistent – selected objects always remained selected until you deliberately de-selected them. Altium Designer includes an option to mimic that behavior, if you disable the Click Clears Selection option in the Schematic – Graphical Editing page selected objects will remain selected until you deliberately clear the selection. It is recommended you try the standard behavior first, and if you need to ‘hold’ the selection state of a set of objects, use the Selection Memory feature (see 3.3.8.2).

Note: If you find that you keep inadvertently selecting certain objects, you can make them harder to select by enabling the Shift Click to Select option in the Schematic – Graphical Editing page of the Preferences dialog. Click the Primitives button to configure which objects require Shift to be held during selection.
3.3.8.1 Selection hints

- Before starting a selection, it is a good idea to de-select all objects first.
- Only items that fall completely inside the selection area are selected.
- The selection color is set in the Graphical Editing page of the Preferences dialog.
- The Move menu allows you to move selections:
  - without maintaining connectivity (move)
  - Maintaining connectivity (drag).
- The S key pops up the Select menu.
- The X key pops up the Deselect menu.

3.3.8.2 Selection memory

Eight selection memories are available in the Schematic and PCB editors, which can be used to store and recall the selection state of up to eight sets of objects on the schematic or PCB. Select the objects you want to remember using any of the methods described above in Table 5, and then store them for quick recall later.

The following selection memory options are available:

- Store in memory (CTRL + number 1 to 8)
- Add to memory (SHIFT + number 1 to 8)
- Recall from memory (ALT + number 1 to 8)
- Recall and Add from memory (SHIFT + ALT + number 1 to 8)
- Apply memory as a workspace filter (SHIFT + CTRL + number 1 to 8).

You can also access the selection memories using the Edit » Selection Memory sub-menu.

Alternatively, use the Selection Memory control panel that is opened by clicking the button next to the Mask Level button (bottom right of the workspace), or pressing CTRL+Q. Click on a STO button to store a selection or RCL to recall a selection. The filtering options at the bottom of the control panel will determine how the selection is displayed.

To prevent accidentally overwriting a selection memory, enable the Confirm Selection Memory Clear option in the Schematic – Graphical Editing page of the Preferences dialog. Selection Memory locations can be locked from being overwritten by checking the Lock checkbox associated with that selection memory.

Figure 16. Selection Memory control panel
3.3.9 Masking

As well as regular selection in Altium Designer, there is also the concept of masking where objects are masked out from view and manual selection. There are many ways to apply a mask to Schematic objects which includes, Find similar objects, navigator panel, messages panel, select connection or Autofocus.

When a mask is set the schematic objects appear in a transparent like mode as shown in Figure 17. When in this mode, you can run Edit » Select » All and only the objects that are not masked out will be selected.

![Figure 17. A schematic showing masked mode.](image)

3.3.9.1 Clearing a mask

To clear a mask in schematic click on the **Clear Button** located in the bottom right of the Altium Designer screen.

3.3.9.2 Changing the mask level

To change the mask level click on the **Mask Level Button** located in the bottom right of the Altium Designer screen. Once clicked, a small popup appears were the mask level is set with sliders as shown to the right. Move the filter slider down to mask more or up to mask less.
3.3.10 Other mouse actions

The mouse operations listed below are universal throughout the Schematic Editor and should be used in preference to menu commands:

<table>
<thead>
<tr>
<th>Keystroke</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Click-and-hold on object</td>
<td>Move an object</td>
</tr>
<tr>
<td>CTRL+click on object</td>
<td>Drag an object whilst maintaining connectivity. Press SPACEBAR to change mode.</td>
</tr>
<tr>
<td>Double-click on object</td>
<td>Edit an object’s properties</td>
</tr>
<tr>
<td>Left-click</td>
<td>ENTER</td>
</tr>
<tr>
<td>Right-click</td>
<td>ESC</td>
</tr>
</tbody>
</table>

*Table 7. General mouse shortcut summary*

While an object is on the cursor, the following keystrokes can be used:

- SPACEBAR to rotate
- X key to flip around the vertical axis
- Y key to flip around the horizontal axis.

3.3.11 Multiple objects at the same location

When working in the Schematic Editor, the situation sometimes occurs where a click to perform an operation is made where there are multiple objects. In this situation, the Schematic Editor pops up a menu listing all the objects it has detected at the location of the click. You can then select the object you wish to operate on from this menu.

![Figure 18. Menu listing objects at mouse click point](image)

3.3.12 Smart Paste

The Schematic Editor’s Smart Paste feature allows you to transform the copy of the selected objects into other objects as you paste them. For example you could copy a selection of Net Labels, and Smart Paste them as Ports, or the selected Sheet Entries could be pasted as Ports+Wires+Net Labels, all in a single paste action.

- Create a set of selected objects in the normal way, for example net labels, then copy them to the clipboard (Ctrl+C).
- Choose Edit » Smart Paste from the menus (Ctrl+Shift+V), to display the Smart Paste dialog, as shown in Figure 19.
3.3.12.1 Choose the objects to paste section

This section displays a list of all the objects in the clipboard, grouped by their type. The check box allows you to control which set of objects you would like to paste. Before you can paste you also need to select a Paste Action, this determines how your selected objects will be placed onto your schematic sheet.

3.3.12.2 Choose Paste Action section

Before you can paste you also need to select a Paste Action. This determines how your selected objects will be transformed as they are placed onto your schematic sheet. The Paste As action called Themselves is a standard paste operation. The other options allow you to transform the source object into a different object, or collection of objects, when pasting.

The possible transformations include:

- Ports, Sheet Entries or Net Labels can be transformed into equivalent ports, sheet entries, net labels, or one text frame/note or a port and net label set per object (with wires).
- Label, Text Frame or Notes can be transformed into Label, Text Frame or Note.
- Windows Clipboard Text can be transformed into net labels, ports, sheet entries, labels, text frames, notes, or a port and net label set per object (with wires).
- Windows Clipboard Graphics can be transformed into an image.
3.3.12.3 Paste Array section

Enable this option to copy your selected objects as a two-dimensional array. The total number of copies you will create are the number of columns times the number of rows. On clicking Ok, you will be prompted to select a start location on the document, where the array will be inserted. Simply position the cursor at the desired location and click.

Columns

This specifies the number of columns you want in your paste array. Each column will be separated by the Column Spacing setting. Enter positive or negative values for spacing, to determine whether the array will be pasted to the right or left respectively for horizontal placement, or upwards or downwards respectively for vertical placement.

Rows

This specifies the number of rows you want in your paste array. Each row will be separated by the Row Spacing setting. Enter positive or negative values for spacing, to determine whether the array will be pasted to the right or left respectively for horizontal placement, or upwards or downwards respectively for vertical placement.

Text Increment

Select what method you would like to use to increment strings (such as designators) on the copies you are pasting. You can select from the following options:

- **Direction**
  - **None** – do not increment, meaning each copy will have the same strings
  - **Horizontal First** – this will increment strings increasing the value of a string from its predecessor by the Primary amount. The successor string to increment is found by finding the next string in the sequence immediately to the right. Once a row has been re-sequenced, move to the start of the next row above. Pins can also be incremented using the Secondary setting.
  - **Vertical First** – this will increment strings increasing the value of a string from its predecessor by the Primary amount. The successor string to increment is found by finding the next string in the sequence immediately above. Once a column has been re-sequenced, move to the start of the next column to the right. Pins can also be incremented using the Secondary setting.

- **Primary**
  - Strings are incremented/decremented from its predecessor by the Primary amount. Pins can also be changed using the Secondary setting.

- **Secondary**
  - Strings are incremented/decremented from its predecessor by the Primary amount. Pins can also be changed using the Secondary setting.

3.3.13 Modifying Polylines

All line objects that have multiple segments are also referred to as polylines – this includes lines, wires and buses. Techniques for modifying a polyline include:

- **Adding or removing a vertex** – To add a new vertex, click once to select the polyline object and display the existing vertices, click and hold anywhere along a segment (the cursor will be a double arrow), press the INSERT key, then move the mouse to position the new vertex. To remove a vertex click and hold on the vertex, and press the DELETE key.

- **Moving a segment in the polyline** – Click once to select the polyline, click and hold on the segment, and move it to the new location.
• **Moving a vertex** – click once to select the polyline, then click and hold on the vertex to move it. Note that when you move an end vertex you can also move the cursor to add a new segment. To prevent this occurring hold the ALT key as you move the end vertex.

• **Move an entire polyline** – while the polyline is not selected, click and hold on it and move the mouse to relocate it.

### 3.3.14 Font Management

Fonts are controlled via the *Font* dialog.

- If an object supports direct font editing, you will be able to access the *Font* dialog when you double-click on the string. This dialog is displayed whenever you edit text and click the font *Change* button. The default font for each object-kind is set in the *Default Primitives* page of the *Preferences* dialog.

- Changing the font for text that cannot be edited directly, such as pin names, port names and sheet text, is done via the *Change System Font* button in the *Document Options* dialog (Design » Document Options). This changes the system font for the active document only.

![Figure 20. Font dialog](image)

### 3.3.15 Exercises – Schematic Editor basics

**Zooming and panning**

1. Open the schematic sheet, ISA Bus and Address Decoding.SchDoc, found in the \Altium Designer Summer 09\Examples\Reference Designs\4 Port Serial Interface folder.

2. Experiment with each of the display commands listed in Table 1 using the View menu, shortcut keys and the Main toolbar.

3. Use the mouse wheel to pan and zoom.

4. Select the menu command **Place » Text String (PT)** and experiment with the shortcut keys listed in Table 2 in conjunction with the display commands you have just mastered. To exit the command, press the ESC key or right-click.
5. Now try auto panning. Select the menu command **Place » Text String** again, then move the cursor to an edge of the window. The display will start panning. Hold down the **SHIFT** key while the display is panning. Note the crosshair cursor displaying while the **Place » Text String** command is active.

**Favorites Panel**

1. Bring up the Favourites panel if you don’t already have it on screen by going to the bottom right of Altium Designer and clicking on **System » Favourites**.
2. Zoom into the area of the schematic you want to create a favourite for and in the favourite’s panel right click on it and select **Add current document view**.
3. Now close that schematic and from the favourite’s panel double click on the saved favourite and it’ll open the schematic and zoom in how you had it.

**Selection and mouse actions**

1. Click on a component, e.g. P1. Observe the dashed box indicating it is the selected object.
2. Click on another component, e.g. a capacitor. It will now be the selected object.
3. Click somewhere on the sheet where there are no parts. Nothing will be selected now.
4. Click on the wire to select it. Notice the handles are now displayed.
5. With a wire selected, experiment with moving a vertex and moving a segment (a length of line between two vertices). Add a vertex by clicking and holding on the wire where you want the new vertex, pressing **INSERT** and then moving the new vertex to its new location. Delete the new vertex by clicking on it and pressing **DELETE**.
6. Make sure all objects on the sheet are not selected using **Edit » DeSelect » All (X, A)** or on the main toolbar.
7. Using the click and drag selection feature, select a section of the circuit. Using the **Edit » Copy** menu command, copy the items to the clipboard.
8. Open a new sheet and paste the clipboard contents onto it. De-select the pasted objects.
9. Close the new sheet (no need to save it).
10. Try moving the selected objects on the original sheet using the **Edit » Move** menu commands. Deselect all objects.
11. While holding the **CTRL** key, click on the component U10. You can now drag it around and still maintain connectivity.
12. Click and hold on capacitor C12 and start to move it. While moving it press the **ALT** key, noting how the movement is now constrained to the horizontal or vertical direction only. The choice between constraining horizontal or vertical is defined by the proximity of the cursor to the object – simply push the object in the desired direction to see the effect.
13. Double-click on one of the capacitors. The **Component Properties** dialog displays. You can now edit any of the device’s properties.
14. Close the schematic without saving any changes.