Module 5: Multi-Sheet Design

5.1 Multi-Sheet Design ................................................................. 5-1
  5.1.1 Structuring a multi-sheet design ........................................ 5-1
  5.1.2 Multi-sheet design connectivity ....................................... 5-2
  5.1.3 Constructing the top sheet .............................................. 5-3
  5.1.4 Assigning the sheet numbers and total number of sheets .... 5-6
  5.1.5 Checking sheet symbol to sub-sheet synchronization ......... 5-7
5.1 Multi-Sheet Design

5.1.1 Structuring a multi-sheet design

All but the smallest designs will need to be laid out over multiple schematic sheets. There are essentially two approaches to structuring a multi-sheet design, either flat, or hierarchical. A flat design is one where the connectivity between nets that span sheets is directly from one sheet to the other or potential to many others.

While a flat design is acceptable for a design with a small number of sheets and nets, perhaps 6 sheets, it becomes unwieldy when the design is larger. Since a net can go to any of the other sheets, a larger flat design needs navigation instructions to guide the reader as they attempt to find that net on the other sheets. The advantage of the flat design is that there are normally fewer sheets, and less wiring to draw.

A hierarchical design is one where the structure – or sheet-to-sheet relationships – in the design is represented. This is done by symbols, known as sheet symbols, which represent lower sheets in the design hierarchy. The symbol represents the sheet below, and the sheet entries in it represent (or connect to) the ports on the sheet below. The advantage of the hierarchical design is that it shows the reader the structure of design, and that the connectivity is completely predictable and easily traced, since it is always from the child sheet up to the sheet symbol on the parent sheet.

The diagram below shows the top sheet for the Temperature Sensor project. Each sheet symbol represents a child schematic in the design.

![Temperature Sensor top sheet](Figure 1. Temperature Sensor top sheet)
5.1.2 Multi-sheet design connectivity

Multi-sheet designs are also defined at the electrical (or connective) level by net identifiers which provide the ‘glue’ between nets in schematic sheets.

5.1.2.1 Net identifiers

Net identifiers create logical connections between points in the same net. This can be within a sheet, or across multiple sheets. Physical connections exist when one object is attached directly to another electrical object by a wire. Logical connections are created when 2 net identifiers of the same type (eg, two net labels) have the same Net property. Note that logical connections are not created between different net identifiers, for example a port and a net label. The only exception to this is when a port connects to a sheet entry of the same name, in the sheet symbol that represents the sheet the port is on (more on this later).

Net identifiers include:

- **Net Label** – Use a net label to uniquely identify a net. This net will connect to other nets of the same name on the same sheet, and can also connect to nets of the same name on different sheets, depending on the connectivity mode defined for the design (referred to as the net identifier scope). Net labels are attached to individual wires, part pins and buses.

- **Port** – Depending on the method of connectivity, a port can connect horizontally to other ports with the same name, or vertically to a sheet entry with the same name.

- **Sheet Entry** – When the connectivity is vertical, you can use a sheet entry to connect to a port of the same name on the sheet below. A sheet entry is added to a sheet using the Place » Add Sheet Entry command.

- **Power Port** – All power ports with the same name are connected throughout the entire design.

- **Hidden Pin** – Hidden pins behave like power ports, connecting globally to nets of the same name throughout the entire design.

5.1.2.2 Net identifier scope

When you create a connective model of a design, you must define how you want these net identifiers to connect to each other – this is known as setting the Net Identifier Scope. The scope of net identifiers is specified in the Options tab of the Project Options dialog. The scope of net identifiers should be determined at the beginning of the design process.
There are essentially two ways of connecting sheets in a multi-sheet design: either horizontally, directly from one sheet, to another sheet, to another sheet, and so on; or vertically, from a sub-sheet to the sheet symbol that represents it on the parent sheet. In horizontal connectivity, the connections are from port to port (net label to net label is also available). In vertical connectivity, the connections are from sheet entry to port.

The Net Identifier Scope specifies how you want the net identifiers to connect:

- **flat** – ports connect globally across all sheets throughout the design. With this option, net labels are local to each sheet; they will not connect across sheets. All ports with the same name will be connected, on all sheets. This option can be used for flat multi-sheet designs. It is not recommended for large designs as it can be difficult to trace a net through the sheets.

- **global** – ports and net labels connect across all sheets throughout the design. With this option, all nets with the same net label will be connected together, on all sheets. Also, all ports with the same name will be connected, on all sheets. If a net connected to a port also has a net label, its net name will be the name of the net label. This option can also be used for flat multi-sheet designs, however it is difficult to trace from one sheet to another, since visually locating net names on the schematic is not always easy.

- **hierarchical (sheet entry/port connections)** – connect vertically between a port and the matching sheet entry. This option makes inter-sheet connections only through sheet symbol entries and matching sub-sheet ports. It uses ports on sheets to take nets or buses up to sheet entries in corresponding sheet symbols on the top sheet. Ports without a matching sheet entry will not be connected, even if a port with the same name exits on another sheet. Net labels are local to each sheet; they will not connect across sheets. This option can be used to create designs of any depth or hierarchy and allows a net to be traced throughout a design on the printed schematic.

- The automatic mode automatically selects which of the three net identifier modes to use, based on the following criteria: if there are sheet entries on the top sheet, then Hierarchical is used; if there are no sheet entries, but there are ports present, then Flat is used; if there are no sheet entries and no ports, then Global is used.

**Note:** Two special net identifier objects are always deemed to be global: power ports and hidden pins.

Summary

- If you are using sheet symbols with sheet entries, the net identifier scope should be set to Sheet Entries/Port Connections. If this mode is chosen, the top sheet must be wired.

- If you are not, connectivity can be established via Ports and/or Net labels, so you will use one of the other two net identifier scopes.

- Net labels do not connect to ports of the same name.

5.1.3 Constructing the top sheet

The process of creating a top sheet can be done in a manual fashion, where the sheet symbols are placed, the filename attribute for each is set to point to the correct sub-sheet and the sheet entries are added to correspond to each port on the sub-sheet.

There are also commands to speed the process of creating a multi-sheet design.

The Create Sheet from Symbol command is for top-down design. Once the top sheet is fully defined, this command creates the sub-sheet for the chosen sheet symbol and places matching ports on it.

The Create Symbol from Sheet command is for bottom-up design, creating a sheet symbol with sheet entries based on the chosen sub-sheet. This is the mode we will use now.
5.1.3.1 Exercise – creating the top sheet for the Temperature Sensor project

Refer to Figure 1 to complete this exercise.

1. To create the top sheet, add a new schematic document to the Temperature Sensor project, set the template to A4 and save it as Program Files\Altium Designer Summer 09\Training\PCB Training\Temperature Sensor\Temperature Sensor.SchDoc.

2. Rather than manually placing sheet symbols and editing them to reference the lower sheets, we will use the Design » Create Sheet Symbol from Sheet or HDL command. Select this command from the menus.

3. In the Choose Document to Place dialog, select Sensor.SchDoc.

4. The sheet symbol will appear floating on the cursor. Place the sheet symbol in an appropriate position on the sheet, as shown in Figure 1.

5. Another important point about sheet entries, their I/O type is an independent attribute from their style (the direction they point), unless you have the auto Sheet Entry Direction option enabled in the Schematic tab of the Preferences dialog. The SCL sheet entry was pointing inward when it was on the left, now that it is on the right it will be pointing out if the Sheet Entry Direction option is currently disabled. Open the Preferences dialog and confirm that the option is enabled.

6. Repeat this process of creating symbols for the MCU, LCD and Power sub-sheets. As you place each sheet symbol, you will notice that the sheet entries will appear on both sides of the symbol, depending on their I/O type: Inputs and Bidirectionals on the left, Outputs on the right. Drag the sheet entries onto the correct sides of each symbol, according to Figure 1.

Note: Sheets with no ports and even blank sheets if they are to be included in the hierarchy require having a sheet symbol created; otherwise the compile process fails to see these sheets.

7. Place the connector. It is a Header 3X2A, which can be found in the Miscellaneous Connectors.IntLib (one of the two integrated libraries installed by default).

8. Enable the Place Sheet Entries Automatically option in the Schematic – Graphical Editing page of the Preferences dialog. Use this feature to automatically place the sheet entries on the sensor schematic sheet symbol.
9. Wire the top sheet as shown in Figure 1.

10. Save the top sheet.

This completes the capture phase of the design process. To confirm that the project hierarchy is correct we will now compile the design. This is covered in detail in section Module 6 – Building the Project, for now we will simply compile to show the correct structure of the design in the Projects panel.

11. To compile the project, select Project » Compile PCB Project Temperature Sensor.PrjPcb, or you can run the shortcut CC. Make sure you run the correct compile command, as there are two in the Project menu. One compiles the current schematic document, the other compiles the whole project.

We want to compile the project.

12. Save the Project (right-click on the project in the Projects panel)

The design is now complete. However, before it can be transferred to PCB layout there are a few other tasks to complete, these include:

- Assigning the sheet numbers for each sheet in the hierarchy
- Assigning the designators
- Checking the design for errors

Figure 4. Sheet entries can be placed automatically

Figure 5. The project hierarchy is displayed once the project has been compiled.
5.1.4 Assigning the sheet numbers and total number of sheets

Sheet numbering is performed using documents parameters, linked to special strings placed on the schematics, as described earlier in Module 4 - Schematic Capture. Sheets can be automatically numbered by selecting the Tools » Number Schematic Sheets command.

- The Sheet Numbering dialog can be used to
  - number the sheets (SheetNumber parameter),
  - set the document number (DocumentNumber parameter),
  - set the total number of sheets (SheetTotal parameter).
- Click in the column to be edited to access the commands to edit that column.
- The sheets and documents can be numbered in a variety of ways, to do this click in the SheetNumber column, then click the Auto Sheet Number button.
- Cells can be edited manually, select the target cell(s), then right-click and select edit (or press the SPACEBAR). Alternatively, use the Move Up and Move down buttons, the number the sheets based on the Display Order.

![Figure 6. Use the Sheet Numbering feature to review and update sheet numbers.](image)

Note: Schematics appear in the Projects panel in the order they were added to the project. You can change this order if you want, simply click, drag and drop to re-order them within the Projects Panel.

5.1.4.1 Exercise – Number the sheets

1. Select the Tools » Number Schematic Sheets command in the schematic editor.
2. Sort the order of the schematics to match that of Figure 6 using the Move up and Move down buttons.
3. Press the buttons Auto Sheet Number, Auto Document Number and Update Sheet Count.
4. Press OK to save the changes.

Note: Remember that these values are presented on the schematic sheets using parameters and matching special text strings. To display the values instead of the strings, enable the Convert Special Strings option in the Schematic – Graphical Editing page of the Preferences dialog.
5.1.5 Checking sheet symbol to sub-sheet synchronization

Typically the design hierarchy is not developed in a purely top-down or bottom-up fashion, the reality is that the design will evolve. This means that there will be modifications to the design that affect the net connectivity established between the sheet entries in the sheet symbol and the ports on the sub sheet below.

To manage the sheet entry to port relationships, use the Synchronize Ports to Sheet Entries dialog. Select Design » Synchronize Sheet Entries and Ports to display the dialog.

![Synchronize Ports to Sheet Entries dialog](image)

Figure 7. Use the Synchronize dialog to ensure that sheet entries match with ports. Uncheck the checkbox down the bottom left to show all sub-sheets in the entire design.

The Synchronize dialog can be used to:

- Match any selected Entry to any selected Port (name and IO type will be changed).
- Add or remove Entries or Ports to either the sheet symbol or the sub sheet.
- Edit the name or IO direction of a matched Entry / Port (done in the Links column on the right).

**Note:** Remember that changes made in the Synchronize Ports to Sheet Entries dialog are performed immediately; use the Undo command on each affected sheet to undo any updates.
5.1.5.1 Exercise – Synchronize the sheet entries and Ports

1. From any schematic in the temperature sensor project, run the command Design » Synchronize Sheet Entries and Ports.

2. You may see a problem like the one shown in Figure 7, where the I/O direction of the sheet entry (Input) does not match the I/O direction of the port (Output). You may also see a problem with the 3 sheet entries on the sensor sheet symbol, not having matching ports on the sensor schematic. Both of these can be resolved in the Synchronize Ports to Sheet Entries dialog.

3. To resolve the first problem, we need to determine which direction is correct. Once the correct direction has been determined, select each entry in the columns on the left, and then click on the $\rightarrow$ to drive the sheet entry direction onto the port, or click on $\leftarrow$ to drive the port direction onto the sheet entry.

4. The second problem is that the sheet entries exist, but they have no matching ports. Select all 3 sheet entries as shown in Figure 8, once you do you will have the option of either deleting the sheet entries, or adding ports. Click Add Ports, when you do the dialog will temporarily disappear, the Sensor schematic will become active, and the cursor will have 3 ports on it. Place them anywhere for now, then close the dialog and return to the Sensor schematic and correctly position the ports onto their wires.

5. Save your design.

Figure 7

Figure 8. Problems found - missing ports on a sheet