Module 8: PCB Editor Basics
Module 8: PCB Editor Basics

8.1 PCB Editor Basics ........................................................................................................... 8-1
  8.1.1 PCB Editor User Interface ......................................................................................... 8-1
  8.1.2 View Commands .................................................................................................... 8-2

8.2 PCB design objects ...................................................................................................... 8-4
  8.2.1 General ................................................................................................................... 8-4
  8.2.2 Tracks .................................................................................................................... 8-5
  8.2.3 Lines ..................................................................................................................... 8-7
  8.2.4 Pads ...................................................................................................................... 8-7
  8.2.5 Vias ...................................................................................................................... 8-9
  8.2.6 Arcs ....................................................................................................................... 8-10
  8.2.7 Strings .................................................................................................................. 8-11
  8.2.8 Dimensions and coordinates ................................................................................. 8-13
  8.2.9 Fills ....................................................................................................................... 8-13
  8.2.10 Copper Region .................................................................................................... 8-14
  8.2.11 Keepout objects .................................................................................................. 8-14
  8.2.12 Paste commands ................................................................................................. 8-14
  8.2.13 Exercise – PCB design objects ........................................................................... 8-15
  8.2.14 Favorites Panel .................................................................................................... 8-16
  8.2.15 Snippets Panel ..................................................................................................... 8-16
  8.2.16 Clipboard panel .................................................................................................. 8-17
  8.2.17 Selection ............................................................................................................. 8-17
  8.2.18 Masking & Dimming ......................................................................................... 8-19
  8.2.19 Other mouse operations ..................................................................................... 8-20
  8.2.20 Multiple objects at the same location ................................................................. 8-21
  8.2.21 Jump menu ......................................................................................................... 8-22
  8.2.22 Exercise — PCB basics ...................................................................................... 8-23

Software, documentation and related materials:

Copyright © 2009 Altium Limited.

All rights reserved. You are permitted to print this document provided that (1) the use of such is for personal use only and will not be copied or posted on any network computer or broadcast in any media, and (2) no modifications of the document is made. Unauthorized duplication, in whole or part, of this document by any means, mechanical or electronic, including translation into another language, except for brief excerpts in published reviews, is prohibited without the express written permission of Altium Limited. Unauthorized duplication of this work may also be prohibited by local statute. Violators may be subject to both criminal and civil penalties, including fines and/or imprisonment. Altium, Altium Designer, Board Insight, Design Explorer, DXP, LiveDesign, NanoBoard, NanoTalk, P-CAD, SimCode, Situs, TASKING, and Topological Autorouting and their respective logos are trademarks or registered trademarks of Altium Limited or its subsidiaries. All other registered or unregistered trademarks referenced herein are the property of their respective owners and no trademark rights to the same are claimed.

Module Seq = 8
8.1 PCB Editor Basics

The PCB Editor opens when you open or create a PCB document. It shares all the workspace features offered by the Altium Designer environment.

8.1.1 PCB Editor User Interface

Use of the PCB Editor is consistent with the Schematic Editor, with additional features that are detailed in the following sections.

![PCB Editor workspace](image)

**Figure 1.** PCB Editor workspace

### 8.1.1.1 Layer tabs

A PCB is fabricated as a series of layers, including copper electrical, insulation, protective masking, text and graphic overlay layers. The tabs associated with each layer are located along the bottom edge of the PCB Editor design window. They allow you to switch the current layer and give a visual indication of which layers are currently being displayed and which is the current layer (the highlighted tab). If there are more layer tabs than can be displayed at one time, use the arrows to scroll through the tabs. Layer colors will be displayed to the left of the layer tabs and clicking the layer color will launch the Board Layers and Colors dialog.

**Note:** To switch between signal layers use the numerical pad * key and for all layers use the numerical pad +/- keys.
8.1.2 View Commands

The View commands can be accessed in the View menu or the Main toolbar. The table below lists the main display commands.

<table>
<thead>
<tr>
<th>Menu Command</th>
<th>Toolbar</th>
<th>Shortcut</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fit Document</td>
<td></td>
<td>VD</td>
<td>Fits all objects in the current document window</td>
</tr>
<tr>
<td>Fit Board</td>
<td></td>
<td>VF</td>
<td>Fits all objects located on signal layers in the current document window</td>
</tr>
<tr>
<td>Area</td>
<td></td>
<td>VA</td>
<td>Display a rectangular area of document by selecting diagonal vertices of the rectangle</td>
</tr>
<tr>
<td>Around Point</td>
<td></td>
<td>VP</td>
<td>Display a rectangular area of document by selecting the centre and then a vertex of the rectangle</td>
</tr>
<tr>
<td>View Selected Objects</td>
<td></td>
<td>VE</td>
<td>Fits selected objects in the current document window</td>
</tr>
<tr>
<td>View Filtered Objects</td>
<td></td>
<td>VE</td>
<td>Fits filtered objects in the current document window</td>
</tr>
<tr>
<td>Zoom In</td>
<td></td>
<td>VI</td>
<td>Zooms in on cursor position</td>
</tr>
<tr>
<td>Zoom Out</td>
<td></td>
<td>VO</td>
<td>Zooms out from cursor position</td>
</tr>
<tr>
<td>Zoom Last</td>
<td></td>
<td>VZ</td>
<td>Returns display to its state before the last view command</td>
</tr>
<tr>
<td>Refresh</td>
<td></td>
<td>VR</td>
<td>Updates (redraws) the screen</td>
</tr>
</tbody>
</table>

Table 1. View command summary

The following shortcut keys are very useful for manipulating the view of the document window. These shortcut keys can be used at any time, i.e. even when executing commands.

<table>
<thead>
<tr>
<th>Keystroke</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>END</td>
<td>Redraws the view</td>
</tr>
<tr>
<td>ALT+END</td>
<td>Redraw Current layer</td>
</tr>
<tr>
<td>PAGE DOWN</td>
<td>Zoom out (holds the current cursor position)</td>
</tr>
<tr>
<td>PAGE UP</td>
<td>Zoom in (holds the current cursor position)</td>
</tr>
<tr>
<td>CTRL+PAGE DOWN</td>
<td>View Document</td>
</tr>
<tr>
<td>CTRL+PAGE UP</td>
<td>Massive Zoom In around the current cursor position</td>
</tr>
<tr>
<td>HOME</td>
<td>View pan (pan to centre the current cursor position)</td>
</tr>
<tr>
<td>ARROW KEYS</td>
<td>Moves the cursor by one snap grid point in the direction of arrow</td>
</tr>
<tr>
<td>SHIFT+ARROW KEY</td>
<td>Moves the cursor by 10 snap grid points in the direction of arrow</td>
</tr>
</tbody>
</table>

Table 2. Shortcut keys for PCB view manipulation

8.1.2.1 Autopanning

Autopanning becomes active when executing commands, i.e. when the cursor appears as a crosshair. When in this state, touching any edge of the document window will initiate autopanning.

The autopanning speed is controlled via Autopan Options section of the PCB Editor – General page of the Preferences dialog (Tools » Preferences). Autopanning can also be turned off here.
8.1.2.2 Right mouse panning

You can also use the Right Mouse pan feature to pan across your PCB document.

1. Place the cursor in the PCB Editor workspace.
2. Right-click and hold. A hand symbol displays on the cursor.
3. Move the cursor in the desired direction to pan.

**Note:** Once the cursor is off the sheet, the panning will stop and you will need to release the right button and repeat the process.

8.1.2.3 Displaying connection lines

The View » Connections menu command displays a menu that allows displaying or not displaying of connection lines either by net, component net or the whole board.
8.2 PCB design objects

8.2.1 General

A variety of objects are available for use in designing a PCB. Most objects placed in a PCB document will define copper areas or voids. This applies to both electrical objects, such as tracks and pads, and non-electrical objects, such as text and dimensioning. It is therefore important to keep in mind the width of the lines used to define each object and the layer on which the object is placed.

Most of the PCB design objects are also referred to as primitives that can be edited in the PCB Editor. Components are made up of a variety of primitive objects and are editable only in the PCB Library Editor. Placing components, polygon planes, split planes and rooms will be covered in detail in up and coming modules.

For an example of each PCB design object, open PCB Objects.PcbDoc found in the Practice Documents folder in Altium Designer Summer 09\Examples\Training.

![PCB Editor primitive objects](image)

- The object placement commands are selected using either the Place menu or the Wiring and Utilities toolbars.
- To set the properties of an object while placing it, press the TAB key and the Properties dialog for that object will be displayed.
- Once an object is placed, you can change its properties by double-clicking on it to display the Properties dialog for that object. Alternatively, you can click once to select an object, and then edit the properties in the Inspector panel (F11 to open).
- Set the default properties for each object type in the Defaults section of the Preferences dialog (Tools » Preferences).
The current layer determines the layer on which the object is placed.

8.2.2 Tracks

The Interactive Routing command is used to place tracks with associated net information.

To start Interactive Routing, select the toolbar button or Place » Interactive Routing (PT). Click where you wish to begin the first track and then use the track placement and start/end modes detailed below.

Pressing TAB during interactive routing will display the Interactive Routing dialog where you can set widths, sizes and related design rules.

You can change the signal layer that you are routing on by pressing the * (asterisk) shortcut key on the keypad and a via will be automatically added.

**Track Placement modes**

Once you are in the interactive routing command and have clicked to start the first track, press SHIFT + SPACEBAR to change the placement mode. Each mode defines a different corner style. Check the status bar to see which mode is active.
There are five track placement modes:

1. Any angle
2. 45 degree
3. 45 degree with arc - 45 degree line with rounded corner.
4. 90 degree (horizontal and vertical).
5. 90 degree with arc - horizontal and vertical orientation with rounded corner.

**Note:** The two arc in corner modes use the Corner Style design rule to define the arc size. If the rule includes a range in the setback size then you can adjust the arc within this range during track placement by holding the comma key (,) to make it smaller, or the full stop key (.) to make it bigger.

**Start and Finish modes**

In addition, the track placement modes are supplemented with a Start Mode and a Finish Mode (see image Track Placement Modes above). After you have selected the Track Placement mode, you can press the SPACEBAR to toggle between the Start Mode option and the Finish Mode option.

If a track starts at an object with a net assigned to it, the track will also be assigned to the net. The interactive routing command will adhere to any rules assigned to that net.

A routed net can be highlighted by holding down the CTRL key as you click on it. Use SHIFT+CTRL+CLICK to highlight multiple nets.

### 8.2.2.1 Graphically modifying tracks

When a track segment is selected, three handles appear — one at each end of the segment and one in the middle. Below are the actions that can be performed.

**To re-position a segment end**

1. Place the cursor on one of the end handles.
2. Click and hold the left mouse button.
3. Move cursor (and the attached vertex) to new location. Altium Designer will add track segments to maintain orthogonal/diagonal patterns in the tracks.

**Breaking a track segment in the middle**

1. Place the cursor on the middle handle.
2. Click and hold the left mouse button.
3. Move the cursor. Altium Designer will add track segments to maintain orthogonal/diagonal patterns in the tracks.

**Drag the track segment away from other track segments**

1. Deselect all track segments.
2. Click and hold on the track segment.
3. Drag the segment to a new location.

**Note:** Older versions of Altium Designer and Protel did not support maintaining neat orthogonal/diagonal patterns in the tracks when tracks were dragged – in earlier versions the handle remained attached to the cursor and it was up to the designer to position it to maintain neat track placement. This mode is still available, hold down the Alt key when starting to drag, and release Alt once you are moving. This is discussed in more detail in Module 18 - Routing and Polygons.
8.2.3 Lines

The Place Line command is provided for placing lines other than tracks, such as the board outline or keepout boundaries on non-electrical layers. Line placement behaves exactly the same as track placement during interactive routing; however, lines have no nets associated with them. When placed on non-electrical layers, lines are not constrained by the design rules.

Pressing TAB when placing lines displays the Line Constraints dialog. Note, however, that when you double-click on a line to edit its properties, the Track dialog displays.

To draw lines, select the toolbar button or Place » Line.

8.2.4 Pads

- Place pads using the Place » Pad command or the Place Pad toolbar button.
- Pads are mainly used as part of components but can be used as individual objects, such as testpoints or mounting holes.
Pad properties are set in the Pad dialog that is displayed by pressing the TAB key while placing the pad or double-clicking on a placed pad.

If a pad is to have different sizes on the mid layers or bottom layer, check Top-Middle-Bottom in the Size and Shape section. Click on Full Stack and then Edit Full Pad Layer Definition to edit more complicated stack ups.

Assign a net to the pad, define the pad’s electrical type (i.e. load, terminator or source) and set whether or not the pad’s hole is plated. The NC drilling software selects separate drill tools for plated and non-plated holes.

Pads can be assigned as Top and/or Bottom Layer Testpoints on both Fabrication and/or Assembly.

Pads can be set to Slotted or Square holes

Pads holes can be set as offset from center

A preview is created at the top of the dialog that changes in realtime.

A new shape of rounded rectangle has been added.
• Paste and Solder Mask expansion can be set at the pad level bypassing what ever is set in the design rules.

8.2.5 Vias

• Vias can be placed using the Place » Via command or the Place Via toolbar button, but they are normally placed automatically when you change layers while placing a track. The Autorouter also places vias.

• Via properties are set in the Via dialog which is displayed by pressing the TAB key while placing a via, or by double-clicking on a placed via. The via diameter, hole size, net and Start and Finish layers are set in the Via dialog.

• Setting the Start and Finish layers to any layers other than Top Layer and Bottom Layer automatically assign the via as a blind or buried via. Blind and buried vias can be easily identified as their hole is displayed as two half circles with different colors.

• Vias can be assigned as Top and/or Bottom Layer testpoints on both Fabrication and/or Assembly.

• If a net being manually routed is to connect to an internal power plane, press the / (forward slash) key on the numeric keypad to place a via connecting to the appropriate power plane. This will work in all track placement modes except 'any angle' mode.

• If a via is to have different sizes on the mid layers or bottom layer, check Top-Middle-Bottom in the Size and Shape section. Click on Full Stack and then Edit Full Pad Layer Definition to edit more complicated stack ups.

Solder Mask Expansions

Checking the Specify expansions value check box allows you to override the Solder Mask setting in the design rules by filling in the required expansion in the field provided.

Tenting

Checking the Tenting check boxes causes any Solder Mask settings in the design rules to be ignored and results in no opening in the solder mask for this via.
8.2.6 Arcs

The table below lists the arc placement options:

<table>
<thead>
<tr>
<th>Place Menu Command</th>
<th>Placement Toolbar</th>
</tr>
</thead>
<tbody>
<tr>
<td>Arc (Edge)</td>
<td>![Icon]</td>
</tr>
<tr>
<td>Arc (Centre)</td>
<td>![Icon]</td>
</tr>
<tr>
<td>Arc (Any Angle)</td>
<td>![Icon]</td>
</tr>
<tr>
<td>Full Circle</td>
<td>![Icon]</td>
</tr>
</tbody>
</table>

*Table 3. Arc Placement commands*

- All of the above commands result in an arc object being placed.
- An arc can be placed on any layer.
- Arc properties are set in the Arc dialog that is displayed by pressing the TAB key while placing an arc, or double-clicking on a placed arc.

*Figure 8. Arc Properties dialog*
8.2.7 Strings

- A string is a single line of text that is placed using the Place > String command or the Place String toolbar button.
- String properties are set in the String dialog that is displayed by pressing the TAB key while placing a string, or double-clicking on a placed string. The actual text string to be placed is entered in the Text field.

![String Properties dialog]

**Figure 9. String Properties dialog**

8.2.7.1 Special Strings

To assist in producing manufacturing documentation, special strings are provided. These include strings, such as .Arc_Count and .Component_Count, that display the number of objects in the PCB file when the PCB document is printed or plotted. Other special strings relate to layer names, file names and printing options. The .Comment and .Designator strings are used when
creating component footprints. The .Legend string shows a drill symbol legend when the string is placed on the Drill Guide layer.

While most special strings are only converted during printing or plotting, .Layer_Name, .Pcb_File_Name and .Pcb_File_Name_No_Path can be viewed on screen. To see the values of these special strings placed on a PCB, select Convert Special Strings in the Display tab of the Preferences dialog (Tools » Preferences). For example, the special string .Layer_Name placed on the Top Layer of a PCB document would now display on the screen as TopLayer.

You place a special string using the Place » String command, but instead of filling in the Text field in the String dialog, use the drop-down list to display the special strings (see Figure 10). Select the desired special string, press OK and click to place it.

![Figure 10. String dialog showing special strings](image)

### 8.2.7.2 True Type Fonts

True type fonts can now by used on strings placed in PCB or the PCB library editor. The true type fonts used can be any font that is installed on windows. Using true type fonts gives the extra option of Inverted. Using true type fonts also enables the use of Unicode character sets, like Asian character sets or even ROHS character sets.

One draw back to using true type fonts is if it’s a unique font set and you move the PCB to another machine that doesn’t have it, then that machine is going to read the preference set in Tools » Preferences » PCB Editor » True Type Fonts. There is the option in here of setting the font to embedded which converts it to copper regions and the substitution font.

![Figure 11. Setting the substitution font and embedding the true type font](image)
8.2.8 Dimensions and coordinates

Dimensions and coordinates can be added to the current layer. All measurements and cursor positions are displayed relative to the current origin. The absolute origin (0, 0) for a PCB document is the lower left corner of the design area.

You can set the current origin to be any point in the PCB workspace by selecting Edit » Origin » Set. Click where you want to set the new current origin. To set the current origin back to the absolute origin, select Edit » Origin » Reset.

8.2.8.1 Placing dimensions

Dimensions can be added to the current layer by selecting from the Dimension tools on the Utilities toolbar (View » Toolbars » Utilities) or the Place » Dimension (PD) submenu. Click to define the start and end points. Watch the Status bar for instructions on placing the dimension. Press TAB to set the properties, such as the text height and width. Right-click or press ESC to exit the command.

The dimension value automatically updates as you move the start or end points.

8.2.8.2 Placing coordinates

A coordinate object places X, Y coordinate information measured as the horizontal (X) and vertical (Y) distance of the coordinate marker from the current origin. Select the Place Coordinate toolbar button or Place » Coordinate (PO). Click to place the coordinate. Right-click or press ESC to exit the command. The position values are automatically updated when you move a coordinate object.

8.2.9 Fills

- The Fill object is a solid rectangle and can be placed on any layer. A fill is placed using the Place » Fill command or the Place Fill toolbar button.
- To place a fill, the first click defines a corner of the fill and then the next click defines the opposite corner of the fill. Fill properties are set in the Fill dialog that is displayed by pressing the TAB key while placing a fill, or double-clicking on a placed fill.
- When a fill is selected, you can change its size by clicking and dragging its handles and you can rotate it by clicking on the small circle.

Figure 12. Fill dialog
8.2.10 Copper Region

- The Copper Region object is a multi-sided solid object. Although it is referred to as a Copper Region it can be placed on any design layer, including mechanical, mask, plane, or silkscreen layers.
- A region is placed using the Place » Copper Region command, or the Place Copper Region toolbar button.
- To place a region, click to define each vertex on the multi-sided object, when finished right-click to drop out of vertex placement mode. Region properties are set in the Region dialog that is displayed by pressing the TAB key while placing a region, or double-clicking on a placed region.
- A region can also be used to create a void in a solid or hatched polygon pour.
- A region can be used to create a board cutout region where a mechanical object may require room within a board space.

![Region dialog, and an example of a region](image)

8.2.11 Keepout objects

Tracks, fills and arcs can be used to assign an area on a specific electrical layer to act as a routing barrier. Objects defined as keepouts are ignored by output operations, such as photo plotting and printing.

A keepout can be defined using the commands in the Place » Keepout sub-menu (PK). Existing tracks, fills and arcs can be defined as layer-specific keepouts by selecting the Keepout option in the object’s Properties dialog.

8.2.12 Paste commands

There is an additional paste command in the PCB Editor — Edit » Paste Special. This command can be used for panelizing an entire PCB design or pasting multiple copies of selected objects. However, this does create things like duplicate nets, and large numbers of primitives on the board. A much better way to do this is to use embedded board arrays, which is covered in the Altium Designer Advanced Schematic Capture and PCB Editing training course.

Before using this command, copy selected objects to the clipboard using Edit » Copy (EC) or Edit » Cut. Click to select a reference point, i.e. the point used to hold the selection while positioning it during the Paste operation.

From the Paste Special dialog, you can choose to paste objects on the current layer (selected option) or retain their original layers (deselected). Clicking on Keep Net Name retains the original net names of pasted objects. If this option is not selected, the pasted object’s net attribute is set to ‘No net’.
If components have been copied, the other options will become selectable. The **Duplicate Designator** option should be selected when panelizing an entire design to keep the designator names the same on each panel. Otherwise, generic default designator names are used.

Select the **Add to Component Class** option to make sure pasted components are added to the same class as the components from which they were copied.

---

### 8.2.13 Exercise – PCB design objects

1. Open `PCB Objects.PcbDoc` found in the `\Altium Designer Summer 09\Examples\Training\PCB Training\Practice Documents` folder. Experiment with placing each of the PCB design objects in the spaces provided.
2. Place a few pads and then connect them by placing tracks, using the various track placement modes.
3. Select each object and observe the effect of moving the handles.
4. Double-click on some of the objects to display and modify their properties.
5. Close the PCB document without saving.
8.2.14 Favorites Panel

Like a web browser a list of favourite documents can be stored in this panel for future reference. A thumbnail of the view as well as title and comment is stored. For Altium Designer documents the zoom level and location is included.

Favourites can be tied to the project itself making it a useful mark up tool for design collaboration. Project favourites are stored in a 'ViewsOf' folder in the same folder as the project file.

- Open the Favourites panel from the panel control in the bottom right by going to System » Favorites.
- The contents may be divided into folders. A new folder can be created from the right click menu
- To add the current view to a folder use Add Current Document View from the right click menu
- To recall a view simply double click the entry in the list
- The size of the thumbnails is configured in the System preferences in the View section.

8.2.15 Snippets Panel

The Snippets Panel provides a way to store portions of a design for later reuse. The panel will store sections of schematic, PCB layout and source code.

- Open the Snippets panel from the panel control in the bottom right by going to System » Snippets
- The contents can be divided into folders. These are just regular Windows folders and the location can be configured from the Snippets Folders button. Multiple folders can be defined; using a shared network resource will let you share a snippets library amongst an entire design team.
- To create a snippet select the objects in the PCB, schematic, or code editor and then from the right click menu select Snippets » Create Snippet from selection. File the snippet away with a title and comments.
- To Place a snippet select it in the panel and then click the Place button at the top.
- Ideally reset component designators before using them to create a snippet to avoid duplication when they are placed.
8.2.16 Clipboard panel

The Clipboard Panel provides a way to store portions of a design for later reuse. The panel will store sections of schematic, PCB layout and source code. The only limitation of this panel is the data is only available per session rather than all the time like the snippets panel.

- Open the Clipboard panel from the panel control in the bottom right by going to System » Clipboard
- The clipboard panel has the added advantage of being able to read the windows clipboard so data can be transferred from other programs to Altium Designer. This option needs to be enabled in DXP » Preferences » Systems » General. Turn off the option of Monitor clipboard content within this application only.

8.2.17 Selection

Use the Select function to graphically edit an object. Below are some key points about using select:

- An object becomes selected when you click on it with the left mouse button.
- Clicking on an object that is selected allows you to move it.
- When selected, handles appear at key points on the object. The method for editing objects varies between objects, but typically, a click on a handle enables you to move the handle.
- When placing objects, the last object placed remains selected.
- To de-select an object, simply click in an area of the workspace where there are no objects.

**Note:** PCB components cannot be graphically edited unless you unlock the component primitives. Component footprints are normally only edited in the PCB footprint library.

The PCB Editor provides selection capabilities that are similar, although not identical, to selection in other Windows applications. Below are some key points about selection in the PCB Editor:

- Selected objects can be cut or copied to the clipboard. They can then be pasted elsewhere onto the current PCB file or into another PCB file.
- There are a number of PCB Editor commands that operate on the selected group of objects, e.g. the Tools » Interactive Placement commands.
- The PCB Editor uses a special proprietary clipboard that supports PCB data such as connectivity and layer properties of primitives. When a copy action is performed a graphical metafile representation is also placed on the Windows clipboard, ready for pasting into another Windows application.
To select objects, you can use the following methods.

<table>
<thead>
<tr>
<th>Method</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Click and drag box around</td>
<td>Select all objects enclosed by drag area</td>
</tr>
<tr>
<td>SHIFT+ click</td>
<td>Select several objects (on a selected object this will de-</td>
</tr>
<tr>
<td></td>
<td>select it).</td>
</tr>
<tr>
<td>Edit » Select menu (S)</td>
<td>Select Inside Area, Outside Area, Touching Rectangle,</td>
</tr>
<tr>
<td></td>
<td>Touching Line, All, Board, Net, Connected Copper, Physical</td>
</tr>
<tr>
<td></td>
<td>Connection, Component Connections, Component Nets, Room</td>
</tr>
<tr>
<td></td>
<td>Connections, All on Layer, Free Objects, All Locked, Off</td>
</tr>
<tr>
<td></td>
<td>Grid Pads or Toggle selection.</td>
</tr>
<tr>
<td>Select Inside Area</td>
<td>This button on main toolbar</td>
</tr>
</tbody>
</table>

Table 4. Select command summary

Once objects have been selected, you can:

<table>
<thead>
<tr>
<th>Function</th>
<th>Menu command</th>
<th>Shortcut keys</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cut</td>
<td>Edit » Cut</td>
<td>CTRL+X</td>
</tr>
<tr>
<td>Copy</td>
<td>Edit » Copy</td>
<td>CTRL+C</td>
</tr>
<tr>
<td>Paste</td>
<td>Edit » Paste</td>
<td>CTRL+V</td>
</tr>
<tr>
<td>Delete</td>
<td>Edit » Clear</td>
<td>CTRL+DELETE</td>
</tr>
<tr>
<td>Move</td>
<td>Edit » Move » Move Selection</td>
<td>Click-and-hold, or M, S</td>
</tr>
<tr>
<td>Rotate</td>
<td>Edit » Move » Rotate Selection</td>
<td>SPACEBAR</td>
</tr>
<tr>
<td>Flip</td>
<td>Edit » Move » Flip Selection</td>
<td>X or Y</td>
</tr>
<tr>
<td>Align</td>
<td>Edit » Align</td>
<td>A (Align submenu)</td>
</tr>
<tr>
<td>Jump to</td>
<td>Edit » Jump » Selection</td>
<td>J (Jump submenu)</td>
</tr>
<tr>
<td>View</td>
<td>View » Selected Objects</td>
<td>V (View submenu)</td>
</tr>
<tr>
<td>Convert</td>
<td>Tools » Convert</td>
<td>TV (Tools submenu)</td>
</tr>
</tbody>
</table>

Table 5. Selected object command summary

To de-select objects, use the Edit » DeSelect menu (X) commands or the DeSelect All button on the Main toolbar.

**Note:** Selection in earlier versions of Altium software differed from other Windows applications in that selection was persistent – selected objects always remained selected until you deliberately de-selected them. Altium Designer includes an option to mimic that behavior, if you disable the Click Clears Selection option in the PCB Editor – General page selected objects will remain selected until you deliberately clear the selection. It is recommended you try the standard behavior first, and if you need to ‘hold’ the selection state of a set of objects, use the Selection Memory feature.

**Note:** If you find that you keep inadvertently selecting certain objects, you can make them harder to select by enabling the Shift Click to Select option in the PCB Editor – General page of the Preferences dialog. Click the Primitives button to configure which objects require Shift to be held during selection.
8.2.17.1 Selection hints

- Before starting a selection, it is a good idea to de-select all objects first.
- Only items that fall completely inside the selection area will be selected.
- The selection color is set in the Board Layers & Colors dialog (Design » Board Layers & Colors) or use the L shortcut.
- Pressing the S key pops up the Select menu.
- Pressing the X key pops up the DeSelect menu.
- Eight selection memories are available in the PCB editor which can be used to store and recall the selection state of up to eight sets of objects on the PCB.

Note: The PCB editor includes a number of extra selection modes, including Select Touching Line, Select Touching Rectangle and Select Connected Copper. Press S to pop up the Select menu and access these commands.

8.2.18 Masking & Dimming

As well as regular selection in Altium Designer, there are also ways of hiding certain objects from view. Two methods of doing this exist. The first is dimming, which dims out any objects that are not currently of interest. The second is masking, which is similar, but prevents the user from accidentally selecting or changing objects unintentionally. There are many ways to apply a mask/dim effect to PCB objects, including: Find similar objects, navigator panel, messages panel, Using CTRL key or Autofocus.

When a mask or dim effect is set the PCB objects appear darker as shown in Figure 18.

Figure 18. A PCB showing masked mode.
8.2.18.1 Clearing a Mask/Dim Effect

To clear a mask or dim effect in PCB click on the Clear Button located in the bottom right of the Altium Designer screen. The SHIFT + C shortcut can also be used.

8.2.18.2 Changing the Mask/Dim Level

To change the mask or dim level click on the Mask Level Button located in the bottom right of the Altium Designer screen. Once clicked, a small popup appears with the mask and dim levels, as shown below. Move the filter slider to the left to mask more or right to mask less.

![Mask Level setup in PCB](image)

Figure 19. The mask Level setup in PCB

8.2.19 Other mouse operations

The mouse operations listed below are universal throughout the PCB Editor and should be used in preference to menu commands.

<table>
<thead>
<tr>
<th>Mouse Operation</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Double-click</td>
<td>Change an object</td>
</tr>
<tr>
<td>Click</td>
<td>ENTER</td>
</tr>
<tr>
<td>Right-click</td>
<td>ESCAPE</td>
</tr>
</tbody>
</table>

Table 6. General mouse shortcut summary
8.2.20 Multiple objects at the same location

When working in the PCB Editor, the situation often occurs where a click to perform an operation is made where there are multiple objects. In this situation, the PCB Editor displays a menu listing all the objects it has detected at the location of the click, with a small preview of the object currently chosen in the menu. You can then select the required object off this menu.

Figure 20. Menu listing objects at mouse click point

As well as the above there is also the shortcut **SHIFT + X** which gives a similar popup but it shows you what the object is part. For example a track and what net it’s part of and what the whole net looks like.

Figure 21. Menu listing objects when using shift + x shortcut
8.2.21 Jump menu

The Jump menu commands provide you with a number of commands for positioning the cursor. The Jump sub-menu commands are described as follows:

<table>
<thead>
<tr>
<th>Menu Command</th>
<th>Shortcut</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Absolute Origin</td>
<td>JA</td>
<td>Positions the cursor at the Absolute Origin. CTRL+HOME also does this.</td>
</tr>
<tr>
<td>Current Origin</td>
<td>JO</td>
<td>Positions the cursor at the Origin. ctrl+end also does this.</td>
</tr>
<tr>
<td>New Location</td>
<td>JL</td>
<td>Positions the cursor at a specified coordinate.</td>
</tr>
<tr>
<td>Component</td>
<td>JC</td>
<td>Positions the cursor over the specified component.</td>
</tr>
<tr>
<td>Net</td>
<td>JN</td>
<td>Positions the cursor over a pad assigned to the specified net.</td>
</tr>
<tr>
<td>Pad</td>
<td>JP</td>
<td>Positions the cursor over the specified pad.</td>
</tr>
<tr>
<td>String</td>
<td>JS</td>
<td>Positions the cursor over the specified text string in the PCB file.</td>
</tr>
<tr>
<td>Error Marker</td>
<td>JE</td>
<td>Positions the cursor over the next DRC error marker.</td>
</tr>
<tr>
<td>Selection</td>
<td>JT</td>
<td>Zooms in on the selected group.</td>
</tr>
</tbody>
</table>

Table 7. Jump menu commands

If a Jump command does not appear to jump to the correct location, zoom in to display the correct coordinates.
8.2.22 Exercise — PCB basics

1. **Open** 4 Port Serial Interface.PcbDoc, located in the `\Altium Designer Summer 09\Examples\Reference Designs\4 Port Serial Interface` folder.

2. Work through some of the commands in Table 1 to Table 7 in this section to get familiar with the PCB display and selection commands listed. Try using the commands from the toolbar and using shortcut keys.

3. Go to the menu **Design » Board Layers and Colors** (L) and turn off the Visible Grid 2. Go to **Design » Board Options** and set Visible Grid 1 to 50 mil and set the Snap Grid to 25 mil.

4. Place a Solid Region using the **Place » Solid Region** menu command. Observe that when you exit this command the solid region is selected. Move the handles by clicking on them. Move the solid region by clicking on the object. De-select the object by clicking at a point away from any object.

5. Perform the **View » Fit Document** (VD) command on your PCB file.

6. Move a component by clicking and holding on it.

7. While you are moving the component, press the SPACEBAR to rotate it (SHIFT+SPACEBAR for clockwise rotation) and press the L key to flip the component to the other side of the board (you may need to enable layers to see all the component primitives when it is on the bottom layer).

8. Click another component and start to move it. While moving it, hold the **Alt** key. Note that this will constrain the movement to a vertical, horizontal, or diagonal line from the starting point. The choice between directions is defined by the proximity of the cursor to the object – simply push the object in the desired direction to see the effect. This feature is particularly useful if you want to move a component and maintain its alignment.

9. Select a group of components (click-and-hold and then drag the cursor over the components).

10. Select the **Edit » Copy** menu command to copy the selected group to the Altium Designer clipboard. Don’t forget to give the reference location.

11. Select the **Edit » Paste** menu command. The contents of the clipboard will now be moving with the cursor. Rotate and flip the group as you did when moving a component. Place the group of components by clicking at the required location.

12. Close the document without saving the changes.